PfSense does not boot: Discovers installation, shuts down immediately



  • Hi folks,
    I've set up pfSense 2.3.2 several months ago - even after installing from scratch I had problems booting into the system, but it eventually worked. Now the system won't boot anymore. My installation resides on an Intel 64bit box (SSD attached to SATA port). When booting the machine, pfSense shows a message "Root mount waiting for: usbus4" or, alternatively, "Root mount waiting for: usbus3 usbus2 usbus1 usbus0"  (which does not make sense as nothing but the keyboard is connected to USB) - then the system just shuts down completely, I barely could read the last message on the screen.

    Then, I decided to disable USB in the BIOS. The system eventually booted further past the pfSense-Logo but then shut down as well.

    I also tried resetting the BIOS to its defaults => No success.

    Of course I tried the boot options suggested here
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#NanoBSD_on_Newer_Hardware

    but nothing changed.

    Any suggestions of what I should try?







  • As you already discovered, pfSense (FreeBSD actually) locks up when it tries to access your USB ports, to see if something (drives) is present.
    This is a BIOS <-> FreeBSD issue. Special is the fact : the USB hardware ports are discovered and installed, but accessing it doesn't work.
    => try to boot with USB activated, but remove every USB device (also mouse and keyboard). You should probably inform the BIOS that booting without keyboard isn't a failure at BIOS boot.
    You could easily use another FreeBSD kernel : use a more recent pfSense install. You could even try 2.4 RC.
    Upgrade your BIOS if possible.

    Image 16134 shows the beginning of the boot, where symlinks are written. This must be your drive, your SSD to SATA disk. Or, it dies …
    Is it slow ? Just wait minutes (people saw hours .... SSD was nearly dead).
    Use another drive or even a old fashioned hard disk.

    Btw : Is this a NANO device ? What pfSense version (exact) did you use ?



  • Thanks - unfortunately, this does not work… I've disconnected all USB devices, same error still occurs. Before installing a new release, I'd prefer to somehow save the existing configuration. Is there any way I can do so? I assume I can mount the SSD when booting from some CD, but I wonder what files I need to copy to a new installation? It's not a Nano device, the SSD is fine as well.

    The strange thing is that the whole setup worked flawlessly, however, it was up and running for months after installing it, never required it to reboot, and during installation it worked fine.

    How can I find out which version exactly I am using at the loader prompt?



  • @aileron:

    I wonder what files I need to copy to a new installation?

    cf/conf/config.xml

    @aileron:

    How can I find out which version exactly I am using at the loader prompt?

    etc/version


Log in to reply