IPv6 6RD breaks on reboot, works after release/renew



  • Hello ladies and gentlemen,

    I have been using pfSense for a couple of years, and ever since I introduced IPv6 (1.5 years ago) I have had this issue. IPv6 works like a charm, and will not break even after months of uptime. The only issue arises after rebooting the pfSense firewall. I am not able to ping IPv6-addresses from the firewall itself, neither are any of it's LAN clients. If I do a WAN release/renew everything works as intended. No errors shown during boot, and no issues shown on the dashboard of pfSense either.

    I am using a 6RD tunnel provided by my Norwegian fiber provider Altibox, with the following settings:
    IPv4 BR address: 213.167.115.92
    IPv4 Prefix: 0
    IPv6 Prefix: 2a01:79c::
    IPv6 Prefix Length: 30
    IPv6 DNS: 2a01:798:0:8012::4

    None of the other pfSense users with the same ISP reports this issue.

    My setup:

    Custom hardware pfSense running 2.4.0-RC (I have tried everything from 2.2 and up to this beta, same issue)
    LAN bridge settings: Track interface (WAN IPv6 interface). SLAAC enabled with stateless DHCPv6 (to help with NTP, DNS mainly, I have tried disabling DHCPv6 without any luck).



  • I have the same problem, I just "save and apply" settings from the WAN configuration page after the reboot.

    Else I use Static IPv6 and DHCPv6.

    You have any idea how to be able to define/set static IP addresses while having DHCP6(or alternatives) on and still be able to use Android devices as they don't support DHCPv6? Also couldn't get the static mapping to be working with DHCPv6, so I do it on the host side instead with "Managed RA". DHCPv6 itself works fine.



  • Also want to mention I use Altibox IPv6 DNS as the monitoring IP for the gateway rather than the gateway IP itself which is blocking PING.