Need serious help with configuring IPv6 in pfSense.



  • My ISP provides IPv6 address and I had been trying to configure it with pfSense so that every device on my network gets an IPv6 address. I read many fourms but I didn't succeed. My network configuration is something like this :

    ISP–------------------>ISP Router------------------------------>pfSense Router------------------------------------->All Devices

    When I connect my devices to ISP router every device gets a unique IPv6 address. I checked it at http://ipv6-test.com and the address matched with the address in ipconfig output.

    The ISP router IPv6 status is attached in the screenshot. Prefix length is 64.

    Can someone provide a link to step by step guide or explain me the steps.

    ![Screenshot (46).png](/public/imported_attachments/1/Screenshot (46).png)
    ![Screenshot (46).png_thumb](/public/imported_attachments/1/Screenshot (46).png_thumb)


  • LAYER 8 Netgate

    What are they giving you as a prefix delegation?

    How is the IPv6 WAN configured? DHCP6? Static?



  • The prefix length is 64. I have no clue what prefix delegation is.

    The wan is configured to use dhcpv6.



  • Ok after a bit of online reading I came to understand my situation. The ISP router acts as a prefix delegating client and requests from ISP prefix delegating server. My ISP router then uses this prefix and assigns IP addresses to the clients, in my case pfSense router.

    How should I configure pfSense to work in such situation.



  • As I mentioned in your other thread, put the ISP's router in bridge mode.  PfSense is a much better firewall/router than what ISPs provide.



  • The problem is ISP Router has no bridge mode. The settings are very limited.



  • @SidMan06052001:

    The problem is ISP Router has no bridge mode. The settings are very limited.

    I've had a few cable modems over the years.  Some I could put in bridge mode myself, other I had to call the ISP.



  • Well when I contacted my ISP the person whom I talked to had no clue ehat I was doing.

    And no this router that I have doesn't allow bridge mode.



  • @SidMan06052001:

    Well when I contacted my ISP the person whom I talked to had no clue ehat I was doing.

    And no this router that I have doesn't allow bridge mode.

    What is the modem make & model?



  • Well the area in which I live has very bad broadband service so I am using a MiFi device connected to pfSense box. The firmware version is fxn_jmr540_r6.1_s. The model is JMR540 but the same model number has different firmwares which have different settings option.


  • LAYER 8 Netgate

    You are probably out-of-luck.

    If the ISP cannot provide simple, router-agnostic instructions for what you basically need to do to get at least one /64 routed behind the router, you should just cut your losses and set up something like a tunnelbroker.net tunnel and stop wasting time on them.



  • Yeah you are right.

    Here is similiar situation.
    https://forum.pfsense.org/index.php?topic=80472.0

    I am out of luck. Thanks everybody for their time.


Log in to reply