[Solved] utorrent server behind two pfsense boxes



  • The problem was not in the firewall settings. I did not need to add any firewall rules to pfsense_1. I added some more torrents and they started downloading/uploading in less than a minute. The torrents I originally tried apparently don't have any seeders available.

    Original post below. Above info added 2017-09-05.


    Placed a second pfsense box between the ISP's modem and my utorrent server and I'm unable to get the nat/firewall/routing correct so the torrent server can upload and download.

    Network layout

    
    ISP modem              --> pfsense_1             --> unmanaged_switch_1 --> pfsense_2 --> unmanaged_switch_2 --> utorrent_server
    WAN: DHCP                  WAN: 192.168.254.253                             WAN: DHCP                            IP: DHCP
    LAN: 192.168.254.254       LAN: 192.168.1.0/24                              LAN: 192.168.17.0/24
    
    

    The torrent server works correctly when connected to unmanaged_switch_1 and completely fails when connected to unmanaged_switch_2

    I use UPnP on pfsense_2 to open and close the torrent server ports.

    Have not made any changes to the ISP modems firewall, routing table, or nat rules.

    I did set pfsense_2 to routing only via System –> Advanced --> Firewall & NAT but that prevented all computers behind pfsense_2 from even pinging pfsense_1. Adding a routing rule probably would have solved this but I haven't tried yet.

    I'd prefer to keep the firewall on pfsense_2 enabled as this the firewall for a raspberry pi cluster that I will eventually be moving from place to place to demonstrate the capabilities of the raspberry pi's.

    I tried adding an NAT port forward rule on pfsense_1 and letting the NAT rule automatically manage the rule under firewall->wan but the torrent server still could not upload or download the torrents.

    NAT rule on pfsense_1:
    Interface: WAN
    Protocol: TCP/UDP
    Source address: any
    Source port: any/any
    Destination address: WAN address
    Destination port: 45526
    Redirect target IP: pfsense_2 WAN IP
    Redirect target port: 45526
    All other options left at default settings

    What should I be looking for in the log files that will help me identify the problem?


Log in to reply