Xrio UBM1000 Won't Boot



  • Hi All,

    I have picked up a device from Xrio from ebay that the seller listed as having been running PFSense. It was cheap so I thought, may as well pick it up. However I appear to have a few issues.

    1. Xrio appear to have gone out of business at some point in the last 5 years so documentation is THIN on the ground

    2. The device has a Console interface that looks like a Null Modem connection, but on trying various recommended settings all I am getting is: ▒ repeated over and over.

    3. There is no VGA…. So It's kinda console or nothing. No great drama, except for Point 2.

    In following on from that however I seem to have hit the biggest issue..... Although it powers on and it Posts (Single Beep) it doesn't appear to progress to any level of boot. I have checked the CF card after it's been powered on for 10mins and cannot see any log generation or anything. Now I am assuming all is not lost as I think it may be alive but there is a Bios setting or something else similar causing headaches but I could do with someone with more experience with these devices.

    Really I have two questions:

    If I can access the Bios via Console What is the correct method for connection method (pinouts and port settings)

    If this is a no go, is there any way to get VGA (there appears to be a 10 pin socket with VGA header near the front of the Board (See images) but 10 Pins sounds somewhat short of VGA standard headers.

    The edge connector on the board looks to be PCI? Is there a riser or something to connect to this? (Again see pictures).

    If there are any other suggestions (other than scrapping it) I am all ears at this point!

    Thank you all in advance!

    Regards

    SONiQz

    Sorry about the somewhat potatocam images, my webcam was the nearest thing I could find at the minute!










  • The headers at the front are both com headers. The one that is connected is probably COM1 and the one next to it is probably COM2. 10 pin is somewhat right for a RS232 connection, they are often paired with normal DB9-IDC connectors.



  • Hi John,

    Thanks, that was kind of my train of thought as I have seen other devices with a similar arrangement but I'd seen that VGA is possible over 10 pin so was being hopeful. With that said however I'm still pretty stuck as to what I can do from here….

    Given that I can't get any level of readable console output on the Console port using a Null Modem cable, are there any suggestions to another method of accessing the device. The 'COM1' port is connected to the LCD front panel PCB (which illuminates but offers no output - no surprise, I expect it would need the OS to pass data to it)

    There is a GPIO header which is 10 pin next to the 'COM1' port, but there is no marking as to it's pinout and they appear to be a narrower gauge pin.

    I've tried writing the nanobsd image to a SATA drive to see if it's a boot order issue but can't see it's doing anything useful.

    Any further suggestions welcome before I call it a lost cause?

    Thanks

    SONiQz


  • Netgate Administrator

    I would expect to see some BIOS output on the console port even if there is no output from the bootloader, which is probably using com1.

    The unreadable characters you're seeing sure look like bad console setting. What speeds have you tried? 38400? 19200?

    It looks to have a 44 pin IDE header and a power cable which I assume it driving the LCD. You could probably boot pfSense from an old laptop drive which you could set to use com2 as console.

    Are those two headers really different pitches? VGA headers often are 2mm rather then 0.1" (2.54mm) as com header usually are.

    Where is the CF card slot on that?

    Steve



  • You won't need full RS232 at first, any GND + TX pin will do. Once you have a TX pin working you can do RX and other stuff.

    Try a breakout board, a buzzer and a multimeter, and figure out what the voltage levels are and what pin 'talks' the most during boot. You might not need a null modem cable.

    Once you have the 'talking' pin, you have probably found TX. Hook it up to your RX and connect GND's together. Then just start trying serial speeds.



  • I'd tried 38400 previously but not 19200, that however appears to be the ticket! I can see it POST - I just need to sort out a boot method and hopefully I'll be good to go!

    Thanks for the help! I am guessing I will be back with some other questions soon!

    SONiQz


  • Netgate Administrator

    Nice. We'll be here.

    That hardware looks like it could be pretty slow by modern standards. Fun project though.  ;)

    The by-pass relays could be extra fun!

    Steve