OpenVPN com acesso mas sem ping



  • Pessoal,

    Configurei um canal de openvpn cliente - servidor. Na rede interna do servidor, eu consigo acessar o pfsense cliente pelo browser pelo IP interno mas não consigo pingar esse ip interno.

    Alguem sabe o que pode estar acontecendo?



  • Segue uma imagem para ilustrar. Esse teste é no lado do servidor.

    ![Sem título.png](/public/imported_attachments/1/Sem título.png)
    ![Sem título.png_thumb](/public/imported_attachments/1/Sem título.png_thumb)



  • Provavelmente o protocolo ICMP esta bloqueado, só criar uma regra de liberação que vai conseguir pingar normalmente.



  • Felipe,

    Criei uma regra na WAN para passar o ICMP e ainda não consigo pingar. Eu não havia bloqueado nada mas criei mesmo assim.

    ![Captura de Tela 2017-09-11 a?s 17.38.47.png](/public/imported_attachments/1/Captura de Tela 2017-09-11 a?s 17.38.47.png)
    ![Captura de Tela 2017-09-11 a?s 17.38.47.png_thumb](/public/imported_attachments/1/Captura de Tela 2017-09-11 a?s 17.38.47.png_thumb)



  • Bom, eu não vou saber especificamente onde você deve criar esta regra, já tentou utilizar uma floating rule entre a rede LAN e a OpenVPN?
    Eu utilizo as floating rules para minhas VLANs, caso eu queria bloquear ou liberar o acesso entre duas redes internas que possuo, talvez possa dar certo no seu ambiente.

    Ficaria desta forma:
    Action : Liberar
    Interface : LAN e OpenVPN
    Direction : qualquer
    Adress Family: IPv4 ou IPv4+6
    Protocol : ICMP
    Origem : LAN net
    Destino : Rede (sua rede da VPN [ex: 10.0.0.0/24])
    (Na origem e destino você pode inverter também. Colocar a origem o endereço de rede e o destino a LAN net)

    Depois é só salvar.

    Caso isto não dê certo, tenta criar esta regra na aba LAN onde a origem vai ser a sua rede VPN e o destino a LAN net ou LAN adress. E se o bloqueio estiver vindo direto da VPN, tem que criar uma regra de liberação de saída na aba OpenVPN, onde o destino é a LAN net.



  • Deixa as regras de portas default e faz um teste de ping. Ou der um tracert e ver onde o pacote está morrendo.



  • Você não disse que está conectado PELA VPN (cliente).
    Pela foto, parece que você está na mesma rede do servidor e o ping não funciona, logo, nada tem a ver com o Openvpn

    Além disso, por padrão o pfsense não pinga mesmo, você tem que liberar o ping através do protocolo ICMP que citaram acima