Ntopng service will not start because Redis service is not running



  • Hi,
    I have fresh installed pfsense 2.3.4 and just restored some of my configuration for Firewall Rules and installed ntopNG. But when I try to access NTopng, I'm getting the following error:

    13/Sep/2017 15:47:23 [Redis.cpp:79] ERROR: ntopng requires redis server to be up and running
    13/Sep/2017 15:47:23 [Redis.cpp:80] ERROR: Please start it and try again or use -r
    13/Sep/2017 15:47:23 [Redis.cpp:81] ERROR: to specify a redis server other than the default

    I already tried the suggestions on https://forum.pfsense.org/index.php?topic=127992.msg706275#msg706275

    but that did not help.



  • Happened to me last weekend, not sure if it was related to the recent ntopng update. I deleted everything in the ntopng database directory and restarted the service. Worked fine thereafter.


  • Banned

    Yeah it happens because redis fucks itself up - which happens at least once every months for me. I stopped using the package. Beyond it being a disk space hog, it's rather useless when you find yourself wiping all the history periodically because the thing has crashed.

    After experiencing Redis and MongoDB in a bunch of applications, I really don't have much good to say about these "fancy" way overhyped NoSQL products. They are unstable immature shit.