Wifi clients disconnect or can't connect at all



  • My setup:

    pfSense (2.3.4 and 2.4.0-RC) running on a Netgate SG-8860.
    Netgear R9000 X10 running in access point mode connected to the SG-8860's "LAN".

    I'm using pfSense as a captive portal and DHCP server. When clients try to connect to the wifi network through the Netgear R9000, some clients can not connect. It will keep spinning when trying to obtain an IP address. I see entries in the pfSense /var/log/dhcp.log indicating that it was offering an IP address. Some other clients will connect without any trouble, but the wifi connection will drop after 5-10 minutes. And some other devices connect without any trouble and stay connected.

    I've take the Netgear R9000 X10 and connected it directly to my cable modem without the pfSense device in the network and everything worked perfectly. All of the clients connected fine and nothing dropped.

    I've also taken an older Belkin router and put it in access point mode and connected it to the Netgate SG-8860 and everything worked properly again.

    Individually all the devices seem to work fine on their own, but when the Netgear R9000 X10 access point is connected to the pfSense Netgate SG-8860, it just won't work properly. I've tried adjusting wifi channels, speeds, done factory resets and firmware upgrades. Any thoughts on what's happening?



  • Hi jcl,
    How many SSID you setup in your router? If you try to disable Captive Portal for a few sec, what happen?