NEW INSTALL SUCCESSFUL - BROWSING SLOW



  • Hi i am a beginner in pfsense.  I installed it in a computer i3 2 nic with 4GB memory.  I was successful in installing it and configuring the interfaces.  My configuration includes DHCP, DNS resolver and an ANY ANY RULE in the FIREWALL and NAT to ALL traffic going out of my WAN.

    My problem - browsing / surfing through internet is very slow.  when I open multiple tabs, only the tab that I am currently on loads. Other tabs will receive err in connection.  Also by observation, it seem initial visit to the website takes forever to load but once its loaded, its faster but still not in the norm.

    Any suggestion and pointers



  • not enough info to go on. (post screenshots)

    if i'd take a wild guess, I would probably start looking at a dns issue.
    use nslookup to verify dns is working


  • Netgate Administrator

    Yup, that^

    Do you have unbound (the DNS Resolver) configured at its defaults?

    Steve



  • Hi thanks to all.  I changed my config to use DNS Forwarder and still the same.  Some screen shots attached.  I am not certain what to attach so I attached some shots where I did configuration.

    The Yahoo Site - as you can see did not load properly.  It took some time. 
    The Harry Potter site (error filename) - is usually what i get.  if I remain focus on this tab and reload it, it will load successfully but it will take sometime.  but if I allow it just to run at the background, it will receive the same error.

    Other shots are some of configurations made.

    By the way,  my pfsense is behind a private network.  thus the wan IP address is 192.168.200.228 where the gateway is 192.168.200.1  and the dns server is 192.168.200.2 .  My pfsense LAN address is 192.168.3.0 network.





    ![lan config.png](/public/imported_attachments/1/lan config.png)
    ![lan config.png_thumb](/public/imported_attachments/1/lan config.png_thumb)
    ![wan config.png](/public/imported_attachments/1/wan config.png)
    ![wan config.png_thumb](/public/imported_attachments/1/wan config.png_thumb)
    ![want config 2.png](/public/imported_attachments/1/want config 2.png)
    ![want config 2.png_thumb](/public/imported_attachments/1/want config 2.png_thumb)
    ![firewall nat.png](/public/imported_attachments/1/firewall nat.png)
    ![firewall nat.png_thumb](/public/imported_attachments/1/firewall nat.png_thumb)
    ![firewall rule.png](/public/imported_attachments/1/firewall rule.png)
    ![firewall rule.png_thumb](/public/imported_attachments/1/firewall rule.png_thumb)
    ![frirewall advance.png](/public/imported_attachments/1/frirewall advance.png)
    ![frirewall advance.png_thumb](/public/imported_attachments/1/frirewall advance.png_thumb)
    ![general setup 1.png](/public/imported_attachments/1/general setup 1.png)
    ![general setup 1.png_thumb](/public/imported_attachments/1/general setup 1.png_thumb)
    ![dns forwarder.PNG](/public/imported_attachments/1/dns forwarder.PNG)
    ![dns forwarder.PNG_thumb](/public/imported_attachments/1/dns forwarder.PNG_thumb)
    ![frirewall advance.png](/public/imported_attachments/1/frirewall advance.png)
    ![frirewall advance.png_thumb](/public/imported_attachments/1/frirewall advance.png_thumb)
    ![dns resolver log.PNG](/public/imported_attachments/1/dns resolver log.PNG)
    ![dns resolver log.PNG_thumb](/public/imported_attachments/1/dns resolver log.PNG_thumb)
    ![log gateways.PNG](/public/imported_attachments/1/log gateways.PNG)
    ![log gateways.PNG_thumb](/public/imported_attachments/1/log gateways.PNG_thumb)


  • Netgate Administrator

    One of your DNS servers you have configured is probably giving bad or slow results.

    Go to Diagnostics > DNS Lookup and run a search for pfsense.org for example. Check all 4 of your configured servers are returning something useful.

    Steve


  • Rebel Alliance Global Moderator

    You also have connectivity problem with your wan… look at all your dpinger alarms..


  • Netgate Administrator

    I see dpinger restarting a number of times, like the WAN was unplugged or some change was made. I only see one alarm there though and it's on WANv6.

    If there is some packet loss on WAN though that would obviously be a problem.

    Steve