2.4.0-RC (arm) Unable to check for updates



  • I reported this on 1 September but it has not gotten any attention so I'm posting this anew.
    https://forum.pfsense.org/index.php?topic=109370.msg744681#msg744681

    Netgate SG-1000
    pfsense 2.4.0-RC (arm)
    built on Wed Aug 23 01:13:55 CDT 2017
    FreeBSD 11.0-RELEASE-p11

    Dashboard continually reports "Unable to check for updates". This started shortly after the 2.4.0 update was installed.

    Also the web interface System->Update reports "Retrieving Unable to check for updates".

    Prior to 2.4.0 I was frequently updating the beta releases.

    regards
    oldunixguy
    ![Screenshot from 2017-09-21 21:27:04.png](/public/imported_attachments/1/Screenshot from 2017-09-21 21:27:04.png)
    ![Screenshot from 2017-09-21 21:27:04.png_thumb](/public/imported_attachments/1/Screenshot from 2017-09-21 21:27:04.png_thumb)


  • Rebel Alliance Developer Netgate

    There was a little glitch in updates around the time of your build but it's possible to move past there, it may just take a little nudging.

    First, go to System > Update, Update Settings tab. Change to development snapshots, save. Then change back to stable and save again. Now try the update check and see if it works.

    If it doesn't work, connect via ssh or the console and run:

    pkg update -f
    

    If that prints any errors, post them here along with the contents of /usr/local/etc/pkg/repos/pfSense.conf and the output of pkg info -x pfsense

    If pkg update -f works, try this command:

    pfSense-upgrade -d
    

    And then post the output of that here if it fails.



  • the update settings "branch" drop down box is empty and when one selects that drop down that is empty.
    I had already tried that from reading about this from a long ago post.,,
    image attached

    I next tried the "pkg update -f" and that resulted in a segmentation fault.
    image attached

    pkg info -x pfsense resulted in a segmentation fault.
    image attached

    /usr/local/etc/pkg/repos/pfSense.conf is a symbolic link to /usr/local/share/pfSense/pkg/repos/pfSense-repo.conf
    for which this file exists but is empty
    the date of this file is around the time that the updates stopped working.

    thanks
    oldunixguy

    ![Screenshot from 2017-09-23 02:05:52.png](/public/imported_attachments/1/Screenshot from 2017-09-23 02:05:52.png)
    ![Screenshot from 2017-09-23 02:05:52.png_thumb](/public/imported_attachments/1/Screenshot from 2017-09-23 02:05:52.png_thumb)
    ![Screenshot from 2017-09-23 02:10:55.png](/public/imported_attachments/1/Screenshot from 2017-09-23 02:10:55.png)
    ![Screenshot from 2017-09-23 02:10:55.png_thumb](/public/imported_attachments/1/Screenshot from 2017-09-23 02:10:55.png_thumb)
    ![Screenshot from 2017-09-23 02:14:53.png](/public/imported_attachments/1/Screenshot from 2017-09-23 02:14:53.png)
    ![Screenshot from 2017-09-23 02:14:53.png_thumb](/public/imported_attachments/1/Screenshot from 2017-09-23 02:14:53.png_thumb)
    ![Screenshot from 2017-09-23 02:20:39.png](/public/imported_attachments/1/Screenshot from 2017-09-23 02:20:39.png)
    ![Screenshot from 2017-09-23 02:20:39.png_thumb](/public/imported_attachments/1/Screenshot from 2017-09-23 02:20:39.png_thumb)



  • Are there any problems to download recover image for SG-1000?
    The other way is to get the proper content of pfSense.conf, I do think you need special one for SG-1000, so may be other SG-1000 users can help you.


  • Rebel Alliance Developer Netgate

    The segmentation fault could be from a couple things. We fixed a bug or two in pkg after that time which could affect it.

    It's a bit harsh but you might be able to work around it by doing this:

    rm /usr/local/etc/pkg/repos/pfSense.conf

    Then edit /usr/local/etc/pkg/repos/pfSense.conf and put in this:

    FreeBSD: { enabled: no }
    
    pfSense-core: {
      url: "pkg+https://firmware.netgate.com/pkg/pfSense_factory-v2_4_0_armv6-core",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    
    pfSense: {
      url: "pkg+https://firmware.netgate.com/pkg/pfSense_factory-v2_4_0_armv6-pfSense_factory-v2_4_0",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    

    Check the key files to see if any of them are missing/zero bytes

    : ls -l /usr/local/share/pfSense/keys/pkg/trusted/
    total 8
    -rw-r--r--  1 root  wheel  95 Aug 23 09:38 beta.pfsense.org.20151223
    -rw-r--r--  1 root  wheel  95 Aug 23 09:38 pkg.pfsense.org.20160406
    : ls -l /usr/local/share/pfSense/keys/pkg/revoked/
    total 0
    
    

    If you see any zero byte files in those directories, such as a file named ".empty", remove them.

    After that, try running "pkg update -f" and see what happens. If that works, do "pkg update -f pfSense-repo" and see if you can still see packages/updates. If so, run "pfSense-upgrade" from a shell prompt at the console/ssh and see what it does.

    Worst case scenario, you may have to backup your config, download a current recovery image from the portal, and then reinstall + restore. It only takes a few minutes to do that.



  • Before I rm the file please confirm that what I see is correct. Because the file you refer to /usr/local/etc/pkg/repos/pfSense.conf is a symbolic link to /usr/local/share/pfSense/pkg/repos/pfSense-repo.conf
    AND that file is zero length

    here are the details:
    [2.4.0-RC][root@pei451.localdomain]/usr/local/etc/pkg/repos: ls -l
    total 4
    -rw-r–r--  1 root  wheel  26 Aug 18 14:30 FreeBSD.conf
    lrwxr-xr-x  1 root  wheel  52 Sep  1 23:29 pfSense.conf -> /usr/local/share/pfSense/pkg/repos/pfSense-repo.conf

    [2.4.0-RC][root@pei451.localdomain]/usr/local/share/pfSense/pkg/repos: ls -l pfSense-repo.conf
    -rw-r–r--  1 root  wheel  0 Aug 31 10:07 pfSense-repo.conf

    Does this change what you want me to do? Because you want me to create a file which breaks the symbolic link.

    thanks
    oldunixguy



  • OK I gave up on hearing back on my question about how to handle the sym link.

    I made the /usr/local/etc/pkg/repos/pfSense.conf the contents you specified.
    The key files were identical to your list

    However, when I run your command I get stopped in my tracks:

    pkg update -f
    Child process pid=37179 terminated abnormally: Segmentation fault

    I think I have reported this seg fault before….

    I still can't update the firmware on this and it is getting really annoying.

    Anyone out there can you suggest another solution?

    thanks
    oldunixguy



  • Hi,
    Never used a device like de "SG-1000" but I understood it boots.
    So you can save the config.
    If you have "the Console cable" (you should have this cable with this kind of devices ;) then …. https://forum.pfsense.org/index.php?topic=140753.msg768666#msg768666
    You'll be up running 2.4.2_1 in less then 5 minutes.



  • Thanks for the reply. I dont have a console cable.
    I have downloaded to my laptop the proper firmware file.
    I can get the ethernet console with putty and I can get the web interface.

    What I cant seem to find is how can using the ethernet interface and use the web interface get the image file from my laptop to the device and get it to update. Or do the same with the network console interface using putty…

    Is this impossible from either on these and that the only way to overcome the bug injected in August's update is to make a console cable?

    thanks
    oldunixguy



  • Devices like the SG-1000 without 'console' => not for me.

    Btw : I'm wrong, the 'doc' says all you need is a USB key …. https://www.netgate.com/docs/pfsense/sg-1000/reinstall-pfsense.html