No internet access



  • I've just installed psSense 2.3.4 on a dell computer. I have added a USB rj45. WAN is on NIC and LAN is on USB.

    Everything is default but not the password.

    At this point I don't have any internet access. I can see the LAN has 192.168.1.1 and WAN has a 172.x.x.x.

    Do I miss something?


  • Netgate Administrator

    By default a client connected to LAN should receive an IP via DHCP, is that happening?

    Can a LAN side client reach the pfSense webgui?

    Can it ping an internet host by IP (8.8.8.8) or by URL (google.com)?

    There could be many reasons why it's not working but USB Ethernet adapters are notoriously bad in FreeBSD/pfSense (and in general!). It may be that the LAN NIC is simply not working.

    Steve



  • I get an ip on the lan.
    I can connect to pfSense gui.
    I can ping8.8.8.8

    But I can't reach www.google.com

    Kenneth


  • Netgate Administrator

    Ok, then you have a DNS problem.

    Try going to Diag > DNS lookup and check google.com from there.

    Check Status > Services and make sure Unbound (the DNS resolver) is running. It should be by default.

    Steve



  • In addition, try configuring the PC you are using to connect to pfsense with a static dns like googles, 8.8.8.8 and see if it reaches the internet.



  • @stephenw10:

    Ok, then you have a DNS problem.

    Try going to Diag > DNS lookup and check google.com from there.

    Check Status > Services and make sure Unbound (the DNS resolver) is running. It should be by default.

    Steve

    I can do a dns lookup on google.com without problem. The Unbound service is running.


  • Netgate Administrator

    Ok when you try to ping google.com from the client on LAN what error do you see? I expect it to report 'cannot resolve host' or similar.

    Manually setting 8.8.8.8 on the client would confirm it as tripplex suggests.

    You might try going to Services > DNS resolver and enabling 'DNS Query Forwarding' and disabling 'DNSSEC'. That will the use the DNS servers configured in General Setup or whatever your ISP is supplying.

    Steve



  • I did a mistake. I wanted to use 8.8.8.8 as my DNS lookup so I typed it in the DNS settings with 8.8.8.4 too and unmarked "Allow DNS server list to be overridden by DHCP/PPP on WAN". So I deleted both and change everything back. Now I got access and when I wanted to use google I ended up to my ISP where they want me to registre my WAN MAC. That I did, so now it is working. But is it not possible to use 8.8.8.8 instead of my ISP?



  • @valnurat:

    …..
    But is it not possible to use 8.8.8.8 instead of my ISP?

    Yep.
    If you prefer that Google knows all about your DNS requests (so they know what your are doing every time) instead of your ISP, then it is ok to switch to them.
    Normally, you shouldn't do this all together, and just use the Resolver -as it is activated by default.


Log in to reply