Problem with NAT Reflection



  • Hello all ,

    I have a pfsense box with 2 Interfaces . WAN and LAN . PFsense has his own wan ip and also has another public ip as a virtual ip and assigned with NAT 1-1 to the private ip of the server behind pfsense. I have a rule to forward all traffic to lan network so firewalling is configured in the server.

    In this server i have an IIS installed .  Problem is that i cannot open the webpage with the public ip of the server . If i try to open with public ip of server it redirect to pfsense web interface.

    I enable the below options ,

    1.Enables the automatic creation of additional NAT redirect rules for access to 1:1 mappings of your external IP addresses from within your internal networks.

    2.Automatically create outbound NAT rules which assist inbound NAT rules that direct traffic back out to the same subnet it originated from.

    It stop redirecting me to pfsense gui but also it wont load the webpage.

    Any ideas ?

    Thanks


  • LAYER 8 Global Moderator

    "If i try to open with public ip of server it redirect to pfsense web interface."

    Why would you use the public IP if your on the inside network, just use the local rfc1918 IP.  Or setup an host override so whatever fqdn you are using resolve to the local rfc1918 address of the server.

    Nat reflection is at best a "hack" at worse an abomination ;)  It would always be the very last choice - and would only really be needed in a case where the public IP is hard coded into something and that in itself is bad out of the gate..

    So did you setup nat reflection in the forward?  What type? Is nat reflection even enabled on pfsense? Look here for guidance - method 2 is the better option.
    https://doc.pfsense.org/index.php/Why_can't_I_access_forwarded_ports_on_my_WAN_IP_from_my_LAN/OPTx_networks



  • Hello and thanks for the reply ,

    Unfortunately it is a customer request. We explain to him that he cant use the private ip but for some reason that we dont know he want to use the public ip.

    Fortunately for some reason after we reboot pfsense the nat reflection work perfect!


Log in to reply