Static IPV6 on BT Infinity



  • Hello all,

    I have a BT Infinity FTTC connection and what turns out to be a dynamic IPV6 assignment.  According to google BT will not hand out a static IPV6 address.  Is there anything that can be done or a workaround to allow a more permanent IPV6 setup?  Thanks!



  • Under system->advanced->networking, save the DUID. In WAN dhcp6c settings, select do not allow release.

    Those are the only things that can be done, they were added to help with the same issue you are having for Sky users, but they apply to any ISP using dhcp6 for IPv6. You will never completely secure the IPv6 address/prefix but those two do make a big difference, failing that you'd need to use an ISP such as Zen, where they do give statics.

    By the way, they were added in 2.4, i did not back port them so if you don't see them, you'd need to update to 2.4.



  • Ah that's annoying.  I'm running on an XTM505 and it's got a 32bit processor in (see output below) so I can't install 2.4 without upgrading the processor.

    Shell Output - sysctl hw.model hw.machine hw.ncpu
    hw.model: Intel(R) Celeron(R) CPU          440  @ 2.00GHz
    hw.machine: i386
    hw.ncpu: 1
    


  • Time to update the hardware methinks..  8)



  • @marjohn56:

    Under system->advanced->networking, save the DUID. In WAN dhcp6c settings, select do not allow release.

    Those are the only things that can be done, they were added to help with the same issue you are having for Sky users, but they apply to any ISP using dhcp6 for IPv6. You will never completely secure the IPv6 address/prefix but those two do make a big difference, failing that you'd need to use an ISP such as Zen, where they do give statics.

    By the way, they were added in 2.4, i did not back port them so if you don't see them, you'd need to update to 2.4.

    Very helpful, thanks!


Log in to reply