Problems with BT Vision & PfSense 2.3.4



  • Hi All,

    I've played with PfSense in the past but only recently started to use it to manage my home network / office (I work from home). I'm still getting my head around advanced networking and PfSense is definitely diving into the deep end.

    I've got everything working (or so I thought I did). My other half informed me that the TV (BT VISION) is not working on our extra channels (IPTV).

    After spending around 2 hours turning a blank I thought maybe someone could point me in the right direction.

    I have setup a WAN interface with static IP as Multicast is not sent over PPoE. To avoid packets flooding my LAN the BT Vision box is on its own VLAN ,The switch it is connected to has IGMP snooping enabled.

    Please see attached screenshots. I'm really hoping someone can help me. I'm sure I'm being really stupid but this is the first time I've ran into this problem.

    Allow packets with IP options to pass. Otherwise they are blocked by default. This is usually only seen with multicast traffic. Is enabled on the VLAN and the WAN interface I setup for the multicast packets.












  • This is a long shot but you can try going to System -> Advanced -> System Tunables.
    Then add an entry for "net.link.ether.inet.allow_multicast" and set the value to 1.

    If you want to remove it remove the tunable and reboot.



  • Hi,

    Thank you for the suggestion. It really is appreciated.

    I would like to avoid doing that if possible. I can see people have managed to get this working in the past without this setting. I wonder if my provider changed something in the past 3 years…

    I've also attached my Outbound NAT rules.

    ![Screenshot (15).png](/public/imported_attachments/1/Screenshot (15).png)
    ![Screenshot (15).png_thumb](/public/imported_attachments/1/Screenshot (15).png_thumb)