Squid transparent proxy on bridged setup.



  • Hi,

    I have squid 2.6.21_07 installed on 2 Alpha-Alpha (build 24 Nov) installed.
    The machine is set up in bridge mode (LAN 192.168.3.252 and WAN is DHCP (192.168.3.107))

    When enabling squid as a transparent proxy on the WAN interface - nothing seems to go via the proxy.
    I amd running squidguard and in transparent mode on the WAN interface it is not blocking, However, if I connect directly to the proxy
    on192.168.3.252 (LAN) port 3128 it works as expected.

    When enabling squid as a transparent proxy on the LAN interface - everything is blocked - and I can't get to any website.

    From pfctl -sa |grep rdr I see the rule:
    rdr on em1 inet proto tcp from any to ! (em1) port = http -> 127.0.0.1 port 80 is added.

    Any pointers will help.

    Regards,

    Shaun



  • Same problem here. Guess we're the only one?

    Not using squidguard, but squid.

    Anyone else that could shed a light on this?

    thx!



  • I can't speak to having Squid bound to the WAN interface, however your issue with everything being blocked via LAN seems like it would be related to the "Allow users on interface" tick box.  Click the box, press save, try the proxy from the LAN.  If that doesn't work, untick it, hit save, then tick it again, and hit save again.  For some reason, the setting needs to be cleared out after certain installs.

    Might I ask why you were trying to use Squid on the WAN side?


Locked