Activating NIC's



  • Hi all,

    I've recently aquired a qotom mini-PC. For the purpose of using it with PFsense.

    It has 4 NIC's. 2 of which are functional as my WAN and LAN1 interface.

    I have assigned the two remaining NIC's in the interface/assign menu. And they show up on the dashboard as OPT 1 and 2.

    But they don't function as I would like to yet…

    I'd like to configure them to work like two extra LAN ports which can communicate with LAN1 and the WAN. Like your basic router would function.

    I've tried some bridging, but I end up with it not working or being completely locked out of the system, which forces me to get back to the setup and restore the previous setting.

    Can somebody help me?.

    Thanks in advance.

    Dimitri.


  • Banned

    You create a bridge with the unused NICs and assign it to LAN. Then you plug the LAN cable into one of the formerly unused NICs. Then you edit the bridge to add the remaining NIC. You'll also need to edit the tunables so that you filter the bridge and not the NICs.

    https://doc.pfsense.org/index.php/Interface_Bridges

    Now - pfSense is NOT a switch. Get yourself a switch, instead of wasting ports and producing sucky performance.



  • Hey dok, off topic - but is it possible to bridge but filter so one port can pass only 802.1x packets via tunables or otherwise?

    I'm assuming no, but thought I'd ask.



  • @doktornotor:

    You create a bridge with the unused NICs and assign it to LAN. Then you plug the LAN cable into one of the formerly unused NICs. Then you edit the bridge to add the remaining NIC. You'll also need to edit the tunables so that you filter the bridge and not the NICs.

    https://doc.pfsense.org/index.php/Interface_Bridges

    Now - pfSense is NOT a switch. Get yourself a switch, instead of wasting ports and producing sucky performance.

    Ok,

    So bridge both opt 1 and 2 in the bridge tab

    Go back to assignments and select both interfaces to the lan bridge.

    Or should i add LAN 1 here?. Or are they automaticly bridged to the LAN1 port?.



  • Ok,

    I have bridged both opt1 and opt2

    Assigned them to the LAN port.

    When I save, I can connect to either one of the newly configured opt 1and 2.

    But when I trie to configure the LAN1 to the bridge it doesn't work…

    I have to disable the DHCP server on LAN1, pfsense tells me.

    When I do this and save, I'm locked out of the system and have to restart from setup and go back to previous settings.

    LAN1 also is not selectable in the opt1 and opt2 bridge and cannot be added....

    Anybody know what is happening?.

    Thx.



  • Follow these instructions… works perfectly. Make sure you know your OPT1 from OPT2 etc.

    https://www.infotechwerx.com/blog/Creating-a-Simple-pfSense-Bridge



  • Marjohn,

    Thanks for your reply.

    But the tutorial does raise a question with me.

    Should I create a bridge?.

    Right now I'm using just the LAN1 port, at which I've connected my TPLINK c5400(as an AP).

    Attached to the AP are 2 switches, to which all my devices are connected.

    Isn't this a better way of doing things than create a bridge and start using the OPT1 and 2 instead.

    It seems to me there are negative sides to using bridges?….

    Thanks.



  • As Dok has already said, you are better of using switches, they are designed for that purpose. You said you could not get it working, so I posted you a link with instructions.



  • Yes, thank you for that.

    So you both say, use switches on LAN1.

    I'll do that.

    Just seemed a waist of 2 network ports. But in the end I'm better off with this config. Apparantly.



  • Multiple ports could be used for multiwan or multilan systems. If you. Don't have those then you really only need two.

    I have Qotom on the way, my intention is to use Esxi and have pfSense and my webserver running on the one device,but it will still.only be using two ports, might even add my mail server to it too if there is sufficient CPU availability, it will still only be using two ports.





  • Same one..



  • Ok, I'm sure it'll be fast enough.

    Thanks for the help!.


Log in to reply