New 2.4.0 Factory install … freezes at end of installer



  • Tried installing new factory 2.4.0 image on a brand new SG-2440… used ZFS... install was pretty smooth but at the end it gives you the option to Reboot ... when chosen, my console just ends with

    All buffers synced.
    Uptime: 7m2s
    umass0: detached
    

    and then the system freezes. Waited about 10 min. Tried hitting <enter>etc. Had to power cycle to get the box to boot.  Not sure if that is expected?</enter>


  • Rebel Alliance Developer Netgate

    Not usually, no. And we've tried a few here and it worked as well without freezing. It may not happen every time, though.

    Does it also happen with UFS?

    Though ZFS is there and has some advantages, we're not officially recommending or advocating for it just yet.



  • It definitely happened w/ me on 2 new SG2440's. Both ZFS. I will try UFS later and report back though…



  • Have not had the chance to try UFS yet, but I did flash another 2440 today and it worked fine (no freeze). The difference - this one had an internal 30GB Intel SSD.  So maybe something about the install process when using the internal eMMC is causing this? Just a tidbit.


  • Rebel Alliance Developer Netgate

    That's entirely possible, and may be the reason I didn't see it. The 8860 I tested on has an SSD and that's where I installed it.



  • Was browsing thru redmine just now and noticed #7307.  So it seems this is offically a bug. Not a huge deal, but just wanted to link here in case anyone else stumbles onto it.


Log in to reply