2.4 Update increased processor usage



  • Hi All,

    I just updated to 2.4 from 2.3.4. I'm using an HP Elitebook with an i7, for some reason after the update I'm seeing 25% (I'm guessing one core) in use all the time. I rebooted and re-ran the installer just to see if it was something with the in place upgrade, but it seems to be an issue regardless of package or settings.

    Under system activity it shows the following. Any ideas?

    _**last pid: 94193;  load averages:  1.15,  1.14,  1.07  up 0+00:28:47    19:24:18
    397 processes: 7 running, 362 sleeping, 28 waiting

    Mem: 958M Active, 47M Inact, 826M Wired, 168K Buf, 5936M Free
    ARC: 349M Total, 13M MFU, 327M MRU, 152K Anon, 1616K Header, 6788K Other
        238M Compressed, 509M Uncompressed, 2.13:1 Ratio
    Swap: 2048M Total, 2048M Free

    PID USERNAME  PRI NICE  SIZE    RES STATE  C  TIME    WCPU COMMAND
      11 root      155 ki31    0K    64K CPU0    0  23:39  90.87% [idle{idle: cpu0}]
      11 root      155 ki31    0K    64K RUN    3  17:51  84.38% [idle{idle: cpu3}]
      11 root      155 ki31    0K    64K CPU2    2  18:50  81.40% [idle{idle: cpu2}]
      11 root      155 ki31    0K    64K RUN    1  17:03  54.88% [idle{idle: cpu1}]
        0 root        8    -    0K  4160K CPU3    3  9:37  32.28% [kernel{acpi_task_2}]
        0 root        8    -    0K  4160K -      3  8:37  30.76% [kernel{acpi_task_0}]
        0 root        8    -    0K  4160K -      0  8:54  29.69% [kernel{acpi_task_1}]
        0 root      -92    -    0K  4160K CPU2    2  0:13  1.86% [kernel{em0 que}]
    27450 root        38    0  267M 35928K piperd  1  0:01  0.49% php-fpm: pool nginx (php-fpm)
        0 root      -16    -    0K  4160K swapin  3  0:39  0.00% [kernel{swapper}]
        4 root      -16    -    0K    32K -      0  0:04  0.00% [cam{scanner}]
    30198 unbound    20    0  1650M  894M kqread  3  0:03  0.00% /usr/local/sbin/unbound -c /var/unbound/
      12 root      -60    -    0K  448K WAIT    2  0:02  0.00% [intr{swi4: clock (0)}]
        0 root      -12    -    0K  4160K -      2  0:01  0.00% [kernel{zio_write_issue_1}]
        0 root      -12    -    0K  4160K -      3  0:01  0.00% [kernel{zio_write_issue_0}]
        0 root      -12    -    0K  4160K -      2  0:01  0.00% [kernel{zio_write_issue_2}]
    87573 root        20    0  240M 31972K nanslp  3  0:01  0.00% /usr/local/bin/php -f /usr/local/pkg/pfb
    35919 root        20    0 37704K  7028K kqread  0  0:01  0.00% nginx: worker process (nginx)**_


  • Rebel Alliance Developer Netgate

    Looks like a lot taken up by ACPI tasks… I can't recall seeing that before, but it's not often people run pfSense on a laptop so it's probably specific to that hardware setup.

    Do you have powerd enabled under System > Advanced, Miscellaneous?

    If not, enable it. If you do, try disabling it.



  • I enabled power daemon and set it between all the modes, the fan slows down a little depending on the selected mode, but usage remains the same for the acpi task. I updated the bios to see if it made a difference as well, but no change. I’ve chalked it up to something with acpi and this version of the kernel in FreeBSD that’s beyond my ability to figure out and rolled back to 2.3.4.

    Thanks for the suggestion.