Update to 2.4.0 fails



  • 2.3.4-RELEASE-p1 (amd64)
    built on Fri Jul 14 14:52:43 CDT 2017
    FreeBSD 10.3-RELEASE-p19

    Upgrading from the UI results in the following error.  Any ideas?

    Updating repositories metadata…
    pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
    Updating Unofficial repository catalogue...
    Fetching meta.txz: . done
    Fetching packagesite.txz: . done
    Processing entries:
    pkg: wrong architecture: freebsd:10:x86:64 instead of freebsd:11:x86:64
    pkg: repository Unofficial contains packages with wrong ABI: freebsd:10:x86:64
    Processing entries... done
    Unable to update repository Unofficial
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    Error updating repositories!
    Failed



  • same problem here



  • I made a real mess of things after this in the console by trying

    pkg-static update –f
    pkg-static upgrade –f

    and

    pkg update -f
    pkg upgrade -f

    and

    'Upgrade from the Console'

    Now WebConfigurator won't even come up.  I tried fixing each referenced file - which usually involved changing .php references to .inc - but to no avail. I'm afraid to restart right now, as my internet connection is currently working.



  • @Sea:

    I made a real mess of things after this in the console by trying

    pkg-static update –f
    pkg-static upgrade –f

    and

    pkg update -f
    pkg upgrade -f

    and

    'Upgrade from the Console'

    Now WebConfigurator won't even come up.  I tried fixing each referenced file - which usually involved changing .php references to .inc - but to no avail. I'm afraid to restart right now, as my internet connection is currently working.

    I had issues upgrading just like you and ended up running the same commands which f*cked things up bigtime. No access to webgui, but internet was working. I did reboot, and after that It was possible or me to reach the gui and also to do the upgrade through shell.



  • I ended up doing a fresh install of 2.4.0 and restoring a configuration I thankfully had saved from May of this year.  Had to reinstall and configure a few things, but I'm up and running again.



  • Ok I just found the cause of this problem. Official upgrade cannot be done if we had installed unofficial repos like WPAD. To be able to update simple edit the unofficial.conf file located in /usr/local/etc/pkg/repos/

    Change these code:

    FreeBSD: { enabled: no }
    
    Unofficial: { url: "pkg+https://github.com/marcelloc/Unofficial-pfSense-packages/raw/master/repo",
    	    mirror_type: "srv",
    	    enabled: yes}
    

    to these code:

    FreeBSD: { enabled: no }
    
    Unofficial: { url: "pkg+https://github.com/marcelloc/Unofficial-pfSense-packages/raw/master/repo",
    	    mirror_type: "srv",
    	    enabled: no}
    

    By disabling the unofficial repo the system update will work.



  • @remzej:

    Ok I just found the cause of this problem. Official upgrade cannot be done if we had installed unofficial repos like WPAD. To be able to update simple edit the unofficial.conf file located in /usr/local/etc/pkg/repos/

    Change these code:

    FreeBSD: { enabled: no }
    
    Unofficial: { url: "pkg+https://github.com/marcelloc/Unofficial-pfSense-packages/raw/master/repo",
    	    mirror_type: "srv",
    	    enabled: yes}
    

    to these code:

    FreeBSD: { enabled: no }
    
    Unofficial: { url: "pkg+https://github.com/marcelloc/Unofficial-pfSense-packages/raw/master/repo",
    	    mirror_type: "srv",
    	    enabled: no}
    

    By disabling the unofficial repo the system update will work.

    AHH!  That's it - WPAD. I remember I had to kludge something via an "unofficial" repo but I couldn't remember exactly what it was.  thanks for the info - this helps a bunch.