2.4.0 Upgrade Failed (sort of)



  • Upon clicking the button to proceed with the v2.4.0 upgrade (from 2.3.4_1), I was almost immediately greeted with a "System Update failed!" message in red.  However, as I kept watching the screen, I noticed the progress bar was still progressing periodically.

    The progress bar got about halfway across and then never moved and I lost internet.  So, I did a few errands around the house and came back several minutes later to my internet back on.  While the seemingly failed upgrade process page was still up, I tried accessing PFsense in a new tab and was greeted with a new login page.  After logging in, the dashboard now reads "2.4.0-RELEASE (amd64)", so I guess I'm good to go?  shrug

    I haven't noticed any issues since the upgrade.  I'm just wondering what the deal was with that "System update failed!" message and if there's anyone else out there who's had a similar experience.



  • I had this happen to me as well a few weeks ago when upgrading from 2.3.4_1 to 2.4.0-RC.  The upgrade started, then I got the "update failed" message and shortly thereafter lost connection to the Web GUI.  Thought that the upgrade had broken the system started to prepare to reinstall, but after a couple minutes everything came back up with the 2.4.0 login screen.  I'm not quite sure what caused this problem and error message, but everything has been working fine since then.  The upgrade from 2.4.0-RC to 2.4.0-RELEASE went smooth with no issues whatsoever.


  • Rebel Alliance Developer Netgate

    It looks scary but really unless you see an error message in the output, it only means that the update process lost contact with the GUI when trying to fetch the next set of messages. It continues to run in the background and will finish on its own.

    We've tried a few different fixes for that and it's better now but can still happen on occasion.



  • Same exact thing happened to me.  Ultimately it appears the upgrade was successful.  First roadbump I've ever had upgradeing pfSense and I'll take it compared to upgrade issues I've had with other FreeBSD-based open-source projects cough FreeNAS cough.



  • The output in the "console" box during upgrade - is that saved anywhere? Am I able to see it after upgrade has completed?

    I too got the red "update failed" option - it was on part 17 of 161.

    I went to reload the page and got a message it succeeded (right away) and then it rebooted. 10 minutes later, it was up on the new UI, etc.

    I'm concerned the update didn't complete 100% / the system is not 100% updated. Before I rebuild the box (I just did that 2 months ago, as I was moving to new hardware and wanted a fresh start - it fixed a VPN issue I had for the longest time), I would love to check a log if it exists.



  • I too got the dreaded “System update failed!” message back when I tried upgrading one of my pfSense 2.3.4 boxes to 2.4.0, and I got it again today when I tried upgrading another 2.3.4 box to 2.4.2. I'm really surprised it still has this problem in 2.4.2, and even more surprised that none of the pfSense upgrade documentation mentions this problem.

    Here's what I had to do both times: SSH into your pfSense machine and run the following three commands as root:

    pkg-static install -f pkg
    mv /usr/local/etc/pkg.conf /usr/local/etc/pkg.conf.old
    pfSense-upgrade -d

    Detail:

    When you run “pkg-static install -f pkg” you’ll see the following:

    Updating pfSense-core repository catalogue…
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):

    Installed packages to be REINSTALLED:
    pkg-1.10.1_1 [pfSense]

    Number of packages to be reinstalled: 1

    After you select “y” and it upgrades the “pkg” package it will tell you the following:

    You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed.

    Instead, I renamed it to pkg.conf.old, just in case.

    After you run “pfSense-upgrade -d” to complete the upgrade it will automatically reboot. The reboot will take longer than normal because it will continue upgrading packages after it boots. Eventually, though, the Web interface will load again and you'll see the new Web GUI design.

    Hope that helps someone.
    –Dan