Upgraded 2.3.4-p1 to 2.4.0 With No Issue (Clean Install)



  • Just wanted to throw out a data point that in my specific setup, I upgraded my [home] Production rig with no hiccups.  :)

    1.  I run pfSense on an SSD and have key material like passwords and my PKI root certificate private keys, so I wanted to play with doing an ATA Secure Erase to properly "wipe" the SSD.  I paid $11 for Parted Magic and burned an ISO to CD-R.

    2.  ATA Secure Erase was successful.

    3.  Used Win32DiskImager to copy the 2.4.0-RELEASE Memstick image to a USB flash drive.

    4.  Booted off flash drive.  Installed to SSD in about 5-10 minutes.

    5.  I tried following the Automatically Restore During Install procedure and had a second USB flash drive with \conf\config.xml on it, but it was an encrypted XML file so it didn't work.  It's worked in the past with a plaintext config.xml file.

    6.  Rebooted and manually configured WAN/LAN interfaces from the console.

    7.  Went to a laptop and used the WebGUI to Restore from an encrypted backup file.  It automatically rebooted and started downloading packages.

    8.  Manually rebooted one more time since I had had issues in the past with FreeRADIUS package not loading until another reboot after an upgrade.

    I did run into the gigantic "pfSense" logo but a quick F5 got rid of that.  Long story short, no issues with DNS, DHCP, OpenVPN client tunnels, CPU and RAM utilization.  Everything seems just like 2.3.4-p1.