Php Error after upgrade to 2.4.0



  • Hello Everyone,

    I upgraded to 2.4.0 last night and after the upgrade i now have a Php Error, any suggestions on this ?

    Here is a copy and paste of it. Thanks

    PHP errors

    PHP ERROR: Type: 64, File: /usr/local/pkg/pfblockerng/pfblockerng.inc, Line: 45, Message: require_once(): Failed opening required 'xmlrpc.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') @ 2017-10-14 23:14:09



  • Try to remove and/or then reinstall pfBlockerNG package? It seems like pfblockerng.inc isnt up to date..



  • Thanks for giving me a place to start, but I do not have pfBlockerNG installed, I do see it as an available package to install.



  • The error mentions pfblockerng.inc which isn't present on a regular pfSense installation, so maybe at one time you did try it? And after removing some leftovers are still on the system?

    Can you try installing and then uninstalling the package? That likely will do a better cleanup this time..



  • Thank you PiBa, that worked.

    I installed it and rebooted, the error went away.
    I un-installed it and rebooted and error is still gone.

    Thank you again