Can't mount cd image, error 19 (Solved with workaround)



  • Hello. Having a hard time getting going. I burned the CD image to CD, booted, I get past the boot loader screen. BSD appears to boot fine, but it can't mount the cd image, failing with error 19. I've tried the kern.cam.delay setting, but no joy. I've tried two different cd drives, both in USB 2 and 3 ports. Also tried the USB stick version, same symptoms. Not sure what to do next.

    Hardware:
    ASRock H170M mimi ITX MB
    Intel G4400 Skylate CPU
    8Gig Ram

    Cheers,
    bt


  • Rebel Alliance Developer Netgate

    Try a memstick instead?

    Are you certain you set the cam delay properly? What exactly did you type?



  • I'm pretty sure I set it right, tried several times.  set kern.cam.boot_delay="10000" then boot.

    I tried the mem/USB stick with the same symptoms.

    Cheers,
    bt



  • Success! I borrowed a regular SATA cd drive and it installed fine.

    If anyone wants, I can re-connect the USB drive for troubleshooting.

    Cheers,
    bt



  • Hi,

    My issue is kind of related, am not getting as far you tho, i download the img tried both memstick and the CD ISO i use disk32Imgager to make the bootable which i have seen on youtube videos.

    on this motherboard its F12 BN150N Gigabyte once i hit F12 comes up with the boot options of the OS drive Sata and the USB stick, i select the usb stick and press enter the comes up with a blank screen with a flashing cursor top left corner. tried this on 2 pc's same issue.

    i have made a bootable with unRAID with no problems in the past using win32diskimgager not sure what the issue is

    i have a old AMD system am wanting to change into a PF Sense router

    any help would be great


  • Rebel Alliance Developer Netgate

    That's unrelated to this issue, please start a new thread.