SG-4860 downgrade to 2.3.4 - Installer only sees the device it booted from



  • This is a follow-up from: https://forum.pfsense.org/index.php?topic=137916 (TLDR: 2.4.0 broke my upload speeds, need to downgrade until 2.4.1 comes out.)

    So I'm attempting to downgrade from 2.4.0 to 2.3.4 on a Netgate SG-4860 but unfortunately when I boot from the USB stick I created the installer only sees the USB stick itself. I didn't find much documentation around this particular problem so I figured I'd ask..

    Here's how it's happening:

    • Created a USB stick by dd'ing pfSense-CE-memstick-ADI-2.3.4-RELEASE-amd64.img to the device

    • Plugged in the USB stick to my SG-4860, connected to the serial console using screen then booted from the device

    • Selected the non-express option and noticed that the device it wants to install to is the same as the USB stick it booted from

    So far I've tried multiple USB drives and those that I've been able to boot from all appear to have the same issue. I know the root device itself exists because I can boot back into 2.4.0 without a USB drive plugged in. I've tried running fsck to see if the installer is just ignoring the drive and that didn't seem to help. I suspect there might be something odd around how the bios or installer are handling the underlying hardware for some reason but I'm not exactly sure where to go looking to see if that's the case.

    In terms of the internal disk on the system now, dmesg only shows:

    da0: <generic ultra="" hs-combo="" 1.98=""> Removable Direct Access SCSI device</generic>
    

  • Netgate

    Why not just Quick/Easy? What happens there?

    The ADI image will install to mSATA if there else eMMC. It all happens automatically.

    da0: <generic ultra="" hs-combo="" 1.98="">Removable Direct Access SCSI device</generic>

    That's the target you want.



  • Quick/Easy ends up failing with a lua error…sorry didn't get a log from the last time I tried but it's similar though not identical to this:

    https://forum.pfsense.org/index.php?topic=37177.msg191775#msg191775

    That's the target you want.

    That's the target I see when the router is running, I don't recall seeing it when I've booted into the installer then dropped into single user mode.


  • Netgate

    About the only thing that makes sense based on what you have said is your eMMC is failing.

    The fastest thing to try is installing an mSATA and trying again.