Pkg-Static 100% CPU



  • Hello!

    I was wondering, what's pkg-static and why did it max out my pfSense to 100%? It caused me to have 100% packet loss, thankfully nobody was on. I assume it's to update packages, but why did it trigger itself automatically? I haven't touched that pfSense in days.

    thanks!


  • Rebel Alliance Developer Netgate

    What version of pfSense are you running? What hardware?

    The package data is updated when you load the dashboard for an update check, if you have the dashboard packages widget installed, if you check for updates under System > Update, or load System > Package Manager.

    I have not seen it use 100% CPU for a prolonged period of time, however, and certainly have not seen it cause packet loss.



  • pfSense 2.4 on a singlecore VM from Vultr with 512MB of ram. The CPU was 100% maxed so that's probably why it had 100% packet loss, no free cycles. Just updated pfSense the night before.



  • Same problem here, "pkg-static update " eats one core permanently, tried to kill it and rebooting unsucessfull, it resurrect.

    95479 root          103    0 13120K  5756K CPU1    1  2:28 100.00% pkg-static update

    Machine is running Pfsense 2.3.4 on HP ML110G3 and 4Gb of RAM with Intel NICS

    Latest change on system was zabbix agent install



  • tried to uninstall pfSense-pkg-zabbix-agent32 without sucess, it hangs with the message…

    Please wait while the update system initializes

    And never ends...

    Perhaps that could be the problem? How I can remove the package manually?



  • I’m having the exact same issue on a Netgate SG-3100. I’ve been using it for 2 months without issues. Two days ago I tried to view available packages and it never loaded the list. Soon after I noticed very high CPU usage while my gigabit connection was idling. top -aSH shows pkg-static update at 100% on CPU1 (two cpu unit, so usage is about 70%)

    I’ve tried killing it, but it comes right back. Restarting does nothing. It kicks back up within seconds of booting.

    How can I stop it or reinstall it? It’s an ARM box, and my only access to terminal is through pfsense GUI. Would appreciate any help. The box is running at > 86 degree C now.



  • Looks like the situation is getting worse….

    last pid: 82364;  load averages:  2.42,  2.31,  1.77  up 0+20:56:57    20:45:24
    157 processes: 8 running, 129 sleeping, 20 waiting

    Mem: 22M Active, 63M Inact, 110M Wired, 21M Buf, 1794M Free
    Swap:

    PID USERNAME  PRI NICE  SIZE    RES STATE  C  TIME    WCPU COMMAND
    44125 root      102    0  9256K  5424K RUN    0  13:34 100.00% /usr/local/sbin/pkg-static search -R --raw-format json-compact pfSense-pkg-*
    74780 root      101    0  9256K  5476K CPU1    1  24:38  94.58% pkg-static update
    21698 root        4    0  8860K  5232K RUN    0  9:42  6.40% /usr/local/sbin/openvpn --config /var/etc/openvpn/client1.conf
      11 root      -92    -    0K  160K WAIT    1  3:07  0.39% [intr{mpic0: mvneta2}]
    58221 root        23    0 86072K 28936K piperd  0  0:00  0.29% php-fpm: pool nginx (php-fpm)
      10 root      155 ki31    0K    16K RUN    0  17.9H  0.00% [idle{idle: cpu0}]
      10 root      155 ki31    0K    16K RUN    1  17.7H  0.00% [idle{idle: cpu1}]
      11 root      -92    -    0K  160K WAIT    1  1:03  0.00% [intr{mpic0: mvneta1}]
    23102 root        20    0  8860K  5132K select  0  0:43  0.00% /usr/local/sbin/openvpn –config /var/etc/openvpn/client2.conf
      11 root      -60    -    0K  160K WAIT    1  0:36  0.00% [intr{swi4: clock (0)}]
    38544 root        52  20  6604K  2356K wait    0  0:27  0.00% /bin/sh /var/db/rrd/updaterrd.sh
        7 root      -16    -    0K    8K pftm    1  0:23  0.00% [pf purge]
      11 root      -72    -    0K  160K WAIT    0  0:14  0.00% [intr{swi1: netisr 0}]
        5 root      -16    -    0K    8K e6000s  1  0:12  0.00% [e6000sw tick kproc]
    42505 root        20    0  5976K  3128K select  0  0:09  0.00% /usr/local/sbin/radvd -p /var/run/radvd.pid -C /var/etc/radvd.conf -m syslog
    37554 dhcpd      20    0 10176K  5844K select  1  0:08  0.00% /usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpd.conf -pf /var/run/dhcpd.pid mvneta1
    8523 root        20    0  6132K  2144K select  1  0:07  0.00% /usr/sbin/syslogd -s -c -c -l /var/dhcpd/var/run/log -P /var/run/syslog.pid -f /etc/syslog.conf
        8 root      -16    -    0K    8K -      1  0:06  0.00% [rand_harvestq]



  • Sounds like to me, this puppy just fires up on all cylinders and doesn't care whether you have an Atom or Xeon. Can u schedule this thing in the middle of the night?

    Am Linux newbie but it seems to me this should be no different than Windows/OSX/Nest Thermostat, I want to manually update my stuff so I know what is known-to-be-good. God knows no greatest&latest updates are bug-free. YMMV.