"Complete" Time-Out



  • Hi there,

    I'm encountering a (very) strange problem since the 2.4 upgrade. Almost every day I get a "complete time-out" from pfSense. I know that there are already a handful forum-threads that are regarding the "504 time-out" that's thrown by NGINX / php-fpm for various reasons. I also deactivated the openVPN-widget as I read that it's causing some problems.

    The "complete time-out" I'm speaking about does affect TRAFFIC (so no internet connection in- and outbound). I also tried to SSH in and restart php-fpm, but I can't even reach pfSense's SSH menu. It only shows the welcome message "*** Welcome to pfSense 2.4.0.RELEASE (amd64) ***".

    Quick facts after that time-out occurs;

    • NO traffic (I can just communicate within my LAN, for e.g. reaching my influxdb/grafana server)

    • NO web-gui (neither FQDN, nor IP)

    • NO SSH

    • "Limited" FTP (I can't access /var for example)

    The only thing that helps is a hardware reset.

    Following packages are installed; openVPN, pfBlockerNG, Snort, telegraf and nMap.

    Last detail I can provide for now- of course I can't see the pfSense dashboard, but telegraf is still providing data to my influxdb, here's what my 24h-graph looks like (please see attachment).

    Thank you very much for your time - helping ideas are much appreciated!



  • Hi,

    Same Problem -

    Upgraded to 2.4.0 and dashboard is timing out. Getting "504 Gateway Time-out" and "502 Bad Gateway" from NGINX. Tried to restart (11) web from console, and unable, console keyboard locked up, no console menu.




  • Hi there,

    currently having an uptime of ~ 1 Day 16 Hours w/o any problems (#fingerscrossed). Only thing I changed since my initial post was upgrading pfBlockerNG to 2.1.1_11 and Snort to 3.2.9.5_2.



  • Removed pfBlockerNG working fine - waiting on update

    https://forum.pfsense.org/index.php?topic=138213.0



  • Just updated to the newest version (2.1.2), having an uptime of 2 Days 16 Hours now.



  • Hello,
    I have update to 2.1.2.But it's show 502.How to fix it?Or only reboot system?



  • Well, can you SSH in?

    If YES, then just restart PHP-FPM.

    If NO, then follow @jimp hint "Try Ctrl-Z and then run /bin/tcsh" => https://forum.pfsense.org/index.php?topic=137103.msg754300#msg754300


Log in to reply