Squid proxy reverso , erro TCP_DENIED/403



  • Boa tarde senhores,

    Meu cenário:

    Intenert –---------------- Pfsense (matriz) ----------------VPN site-to-site-------------Pfsense(filial).

    • Tenho webserver na matriz e na filial.
    • rede matriz 10.10.2.0/24 filial 172.16.2.0/24

    Configurei o proxy reverso:

    • General com meu domínio, habilitei porta 80
    • Configurei meus servidores e portas no webserver
    • Configurei no mappings URL e peers.
    • liberei na rules acesso porta 80.

    Tudo funcionava de boa, parou do nada. De fora da empresa eu consigo acessar os servidores da matriz, porem da filial da acesso negado.

    TCP_DENIED/403 0 GET http://localhost:3128/squid-internal-static/icons/SN.png - HIER_NONE/- text/html
    TCP_MISS/503 4369 GET http://xxxx.xxxxxxx.com.br/favicon.ico - ANY_OLD_PARENT/172.16.2.10 text/html
    TCP_MISS_ABORTED/000 0 GET http://XXXX.XXXXXX.com.br/ - ROUNDROBIN_PARENT/172.16.2.10 -

    Firewall na matriz, Atualizei o pfsense (2.4.0)-RELEASE) , atualizei o Squid-3.5.27
    Firewall na filial, Pfsense 2.3.4 e n~eo tem squid,
    Limpei cache
    Configurei os IP Bypass Proxy for These  Destination IPs e Source IPs

    Na minha visão o squid está bloqueando algo.

    Alguém tem ideia?

    Obrigado



  • Se você colocou no bypass não era pra ta bloqueando.



  • Eu até voltei o backup do meu firewall e não deu certo.



  • Nesse caso seria interessante você acompanhar o trafego do pacote via wireshark ou tcpdump e ver onde ele está sendo bloqueado.



  • Consegui resolver com o tcpdump . O proxy reverso estava tudo certinho. O problema estava no Open VPN, quando voltei o backup o OPEN VPN client estava  com IP IPv4 Tunnel Network diferente do Open servidor. Por isso dava acesso negado, conseguia acessar o servidor local, porem voltava com outro IP.

    Obrigado Danilo.



  • Edita o seu primeiro post como RESOLVIDO. Fico feliz por ter dado certo.