PF Sense 2.4 with Asrock J3455-ITX



  • hi,

    anybody able to install pf 2.4 with Asrock J3455-ITX `?

    I had no problems with 2.3.4. However, with 2.4  64-bit it doesn´t even gets into  the install screen, setup



  • does 2.3.4 upgrade to 2.4?



  • I have a similar board (J3455M) and had several problems once the builds switched to 11.1 base.
    Please check my post :

    https://forum.pfsense.org/index.php?topic=137798.0

    The main issues for me were the continuous resets of the xhci system (and the whole USB system), so much so that I reverted to 2.3.4_1. Now it is running smoothly.

    The only problem I still could not figure out (with this new MB) is that the serial ports seems not to be working and my GPS module cannot be used for NTP sync. The hardware is OK (tested with win10), therefore the issue must be with the SW configuration or such….

    I like the board and I really wish the issues will be fixed in future releases...



  • Probably a FreeBSD problem, I'd check out forums upstream to see if you can find a solution.



  • I had some issues with a j3355, checkout:
    https://forum.pfsense.org/index.php?topic=137411.0



  • My system with J3355-ITX seems to prefer the TSC timecounters without any manual tweaks on 2.4.0 which means the HPET bug is not going to trigger. Go figure.



  • @messerchmidt
    an upgrade works on Asrock J3455-ITX, however it hangs on reboot at "HPET" time
    it doesn´t continue

    same stop on new clean install (CD/USB) etc



  • This worked for me:

    Boot from image

    • At first loader menu choose to boot in safe mode (6,3)
      -  Reboot (1)
    • Complete installation in safe mode
    • Before final reboot choose to add manual changes (goes to prompt)
    • Edit and add to  /boot/loader.conf  ( hint.hpet.0.clock="0" )

    it survived reboot and upgrade.



  • @amunrara,

    as posted before, I followed the same process and managed to install 2.4.0 on my board, but after one week of testing I had to go back to 2.3.4p1. The continuous resets of the USB system (xhci)flooded my email with alarms from nut (my ups is linked to pfSense via USB).
    Please check if you have the same problem with xhci and let me know.

    I still cannot use the serial interfaces, but I plan to do some tests with serial console during the weekend.



  • @amunrara:

    @messerchmidt
    an upgrade works on Asrock J3455-ITX, however it hangs on reboot at "HPET" time
    it doesn´t continue

    same stop on new clean install (CD/USB) etc

    is there a bios update? is htpe set to 64 bit mode?



  • Just got this board and having the same issue on every reboot I have to start in safemode. I may have to reinstall and try the fix posted



  • that or install hyper v server and run it in a vm on same

    https://www.techarp.com/bios-guide/hpet-mode/



  • did the latest 2.4.0-p1 fix it?



  • @messerchmidt:

    did the latest 2.4.0-p1 fix it?

    Just tried 2.4.1 and still had the issue..

    Cant even see it in the bugs list on the redmine page, so it seems we are left for stranded  :'(



  • @maxbet

    I have no issue with USB, my bios is reset to standard.
    the only change I made was on " /boot/loader.conf "

    upgrade to 2.4.1 run without any problems
    I guess, i am just lucky with the board



  • @amunrara

    unfortunately 2.4.1 had the same USB problems for me, but I just realized that I tested it with CSM enabled (support for legacy BIOS). I will try with that option disabled and see…
    This will take some time as cutting internet access does not bode well with the family.

    Edit : correct definition of CSM



  • @amunrara:

    This worked for me:

    Boot from image

    • At first loader menu choose to boot in safe mode (6,3)
      -  Reboot (1)
    • Complete installation in safe mode
    • Before final reboot choose to add manual changes (goes to prompt)
    • Edit and add to  /boot/loader.conf  ( hint.hpet.0.clock="0" )

    it survived reboot and upgrade.

    Just tried this and it worked! (2.4.2)

    For all the newbies out there this is what I had to write to get into the config file
    edit /boot/loader.conf
    also I got a promt during the loading screen, there i hit "Enter" and wrote "exit" before hitting enter once more and after that the loading of the installer continues.



  • Please don't use /boot/loader.conf, it gets overwritten on every single update of the system. Use /boot/loader.conf.local instead.



  • I am in the same dilemma on Asrock J3455B ITX. Currently, I am on 2.3.5 and there is an upgrade to 2.4.1.

    Can I just go to Edit/Boot/loader.conf.local and paste hint.hpet.0.clock="0" on GUI and do the upgrade to 2.4.1? Or do I have to do a clean install?



  • You can leave the entry in /boot/loader.conf.local, the update/upgrade procedure won't touch the file in any way.


Log in to reply