2.4.0 - Memory leak?



  • Hi!

    Upgraded my 2.3.4 to 2.4.0 based on ESXI 6.5.

    I've two boxes with CARP and I see that my primary machine crashes with a message "out of swap space".

    I can see the memory on VMWARE going up and up and then it sits at its full and the machine eventually throws that message.

    My primary box has 2Gigs of RAM and the secondary has 1GB.

    I already tried to increase the RAM but it only delays the problem.

    On pfsense dashboard it shows: 18% of 2003 MiB
    On Vmware dashboard it shows: Consumed host memory 1.31 GB
    Active guest memory 798 MB

    By the way I get this message on VMWARE: "The configured guest OS (FreeBSD (64-bit)) for this virtual machine does not match the guest that is currently running (FreeBSD 11.1-RELEASE-p1). You should specify the correct guest OS to allow for guest-specific optimizations." Probably pure cosmetics?



  • I have the exact same configuration on 2 site.

    VM hosted on VMware 6.5 ESX i (build 6765664) cluster and FreeBSD 64 bits selected.

    I have absolutely no issue at all.

    My VM are very small with 1 vCPU and 1GB of memory.

    Is it coming after an upgrade ? or is it a fresh install? What is ur VMware build version? No ballooning on ur esxi?

    I would suggest to reinstall pfsense and restore ur configuration if u have the possibility to do it.


  • Rebel Alliance Global Moderator

    So maybe you have CD attached to your VM??  See this thread and post to be exact..

    https://forum.pfsense.org/index.php?topic=138054.msg755014#msg755014

    Bug report here
    https://redmine.pfsense.org/issues/6882



  • Going to try that.

    TY!



  • Problem solved with your sugestion ;)