VMware Web Client: "Shockwave Flash has crashed."



  • In case you manage a vSphere environment and have started seeing this Flash crash as of a few days ago, the workaround is below.

    https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2151945

    tl;dr

    Workaround for FireFox:
    Click Start > run, type appwiz.cpl and click Run.
    Uninstall Adobe Flash Player 27 NPAPI Version 27.0.0.170.
    Download https://fpdownload.macromedia.com/pub/flashplayer/installers/archive/fp_27.0.0.159_archive.zip.
    Extract the fp_27.0.0.159_archive.zip\27_0_r0_159\flashplayer27_0r0_159_win.msi.
    Close FireFox.
    Run the extracted flashplayer27_0r0_159_win.msi.
    Click Start > run, type services.msc and click Run.
    Disable Adobe Flash Player Update Service.
    Open the vSphere Web Client in FireFox.

    Workaround for Chrome:
    Download pepflashplayer.7z available at https://bugs.chromium.org/p/chromium/issues/attachment?aid=307292.
    Extract the pepflashplayer.dll to the Desktop.
    Open C:\Users%username%\AppData\Local\Google\Chrome\UserData\PepperFlash\27.0.0.170\ in File Explorer.
    Rename pepflashplayer.dll to pepflashplayer.old.
    Copy the pepflashplayer.dll extracted earlier from the desktop to‘C:\Users%username%\AppData\Local\Google\Chrome\UserData\PepperFlash\27.0.0.170.
    Open the vSphere Web Client in Chrome.


  • Rebel Alliance Global Moderator

    Looks to be good info KOM, thanks..

    I just use the web ui built into esxi, well really the updated fling 1.23.0 but have not seen this issue.  And I am running flash 27.0.0.170..  Wonder if this is problem with just vserver webclient and not the embedded host client?  Or if the updated fling here works around the problem..

    https://labs.vmware.com/flings/esxi-embedded-host-client

    I have not seen this error as of yet.. Does it only happen in specific areas or when trying to do something specific?  The KB article lists when logging in..

    Pretty sure the UI is just native html and javascript - so flash issues would not be a problem with.. But good info to post since many users of pfsense run on vmware..



  • I don't use the updated fling, just the bits that ship with Esxi 6.5U1.

    It happens just as soon as you try to login.  You get the usual blue auth screen, but after you enter your creds and try to login, it crashes.

    Pretty sure the UI is just native html and javascript

    I'm pretty sure the old web client is Flash-based.  The newer HTML5 client is nice but lacks support for the Update Manager plugin, for instance, so it's not as useful.


  • Rebel Alliance Global Moderator

    There are 2 different things here.. There is the UI that is built into the host of esxi (free)  And then there is the web client on the vserver.  I think the issue in the kb article is only on the vserver web interface.

    I updated the embedded because there was a nasty bug on the UI where items were not populating, and you would have to log out and back in.. The 1.23.0 update fixed that.. There is a whole long thread on the fling site.