Forced upgrade? 2.3 pkg repository disabled?



  • Hello,

    I am on 2.3.4-RELEASE-p1 , and can not seem to install any packages.  I get the message.

    WARNING: Current pkg repository has a new OS major version.
            pfSense should be upgraded before doing any other
            operation
    Failed

    2.3.4-RELEASE-p1 was released less then 90 days ago. In a corp environment making infrastructure changes like upgrading firewall is an involved process.  As 2.4 was only released 5 days ago, I am CERTAINLY not installing on production machines. Minimum I'd wait 2-3 weeks to see if any people experienced any issues, install in test environment, most likely wait till at least a point version was released before considered stable/safe.

    Can you please re-enable the 2.3 package repository.



  • Update,  was able to fix. For anyone else experiencing issue.

    System->Update Settings-> Branch

    Change from 'stable' to 'Security/Errata only (2.3.x)'



  • Thank you. That helped me fix the issue.
    By the way what happened to me was that i already had the firewall working.
    I tried to restore a config and the packages couldnt get installed
    i Changed the update settings to 'Security/Errata only (2.3.x)
    than i had to force the packages to be installed from shell
    pkg-static install -f pkg

    after that everything got back to normal



  • @meritan-hima Thanks for the feedback. Same issue happend to me, and your reply helped me a lot. Package installation only worked after the command "pkg-static install -f pkg" from the shell.



  • @clcporto said in Forced upgrade? 2.3 pkg repository disabled?:

    pkg-static install -f pkg

    Thanks for the response, it helped me a lot. my system worked after I gave this command via putty, and then System> Update> Update Settings Legacy stable version (Security / Errata only 2.3.x)