2.4.0 Kernel will not boot



  • Ran across a very peculiar issue.  Did an upgrade from 2.3.4 to 2.4.0, but when it came up, the kernel had a fatal trap 12.

    So I did some troubleshooting:
    Booted  up installed pfSense but used backup kernel, worked fine.
    Attempted to install from 2.4.0 for repair, kernel had fatal trap 12, so issue is with kernel shipped with build, not something files on hard drive.
    Attempted to install from 2.3.0 for repair, kernel did not trap.  Didn't continue further.

    From what I figure there is something with the kernel included with the install with 2.4.0, but not with the backup kernel.  I figure the backup kernel has less things implemented, and believe it has something to do with firewire because before the trap, the status says:

    spb0: <spb-2 scsi="" over="" firewire="">and it stops at:

    Stopped at    fw_busreset+0x220b:

    I cannot disable or remove the firewire port because I am using pfSense on a Thinkpad R60 laptop that has FireWire, so it has to be there, all I can request to see is how to disable the kernel from initializing the device.  I'm a good troubleshooter, but am out of my experience with changing BSD kernels.</spb-2>


  • Rebel Alliance Developer Netgate

    If by "backup kernel" you mean kernel.old, then that would be your old 2.3.4 kernel.

    You can try editing /boot/device.hints and adding a line like this:

    
    hint.spb.0.disabled="1"
    

    You may need to repeat that with other related drivers as well to disable them.

    Or perhaps your BIOS has an option to disable the firewire port.



  • Good tip, tried it, but it still loaded the driver and I got the same error.

    I wish I could disable the FireWire in the BIOS, but there is not an option for that.  Included a screenshot

    https://1drv.ms/i/s!AhoS2mqTo1wfz5MCpr9K1N8eRv3OrA



  • OK, this issue is solved.  I looked further at the error, and needed to apply further debugging techniques. If disabling sdp would not work, go further back. So I disabled the FireWire driver adding this line to /boot/device.hints

    hint.fwohci.0.disabled="1"
    

    Rebooted and firewall came up fine with 2.4.0 kernel just fine.


Log in to reply