[solved] pppoe not working - down event



  • Hi all,

    I am having difficulties configuring PPPoE on my new internet contract. I've spent several days on this issue, and I would be really grateful if someone could help me out.

    Before I describe the issue, a few useful facts:

    • I'm running 2.4.0, fresh install
    • the modem I'm using was working fine with my previous ISP, and pfSense (2.3.*) could connect correctly
    • with the ISP-provided modem/router (a FritzBox) the connection works fine
    • AFAIK, it's a VDSL2 connection (with the FritzBox, I can connect up to ~60Mbit)

    Now, my issue is that the line simply seems down when connecting through pfSense (DOWN Event). I've checked literally dozens of times that the broadband username and password are correct, and I confirmed them with the ISP. I've also confirmed with the ISP that they do not filter MAC addresses. They do require a VLAN ID 10 setting.

    In the pictures below, my configuration.

    WAN interface:

    VLAN:

    PPP interface:

    PPP configuration:

    And this is what I invariably get…

    What am I doing wrong?  :'(

    Thank you so much for any help!!!



  • Who is your ISP?



  • Hi marjohn56, my ISP is DigiWeb, in Ireland.


  • Banned

    What kind of modem do you use? Check that your modem isn't inserting a vlan tag on it's own, overriding the vlan tags from pfSense.



  • My thoughts exactly, if it's like BTOR, the tag is inserted by the modem, not by the router. Just doing some research now.



  • Yes, it appears the VLAN settings are in the VDSL modem. So remove that VLAN setting from pfSense and just try a straight forward PPPoE credentials setting.  What are you using as the modem, that needs the VLAN setting?

    And VLAN is 10.

    I read up on this on this page, where they use a Fritzbox.

    https://www.digiweb.ie/support/broadband-setup/



  • Thanks a lot for the help! Yes, VLAN is 10. That's how I configured it in the pictures above, right? If not, please tell me: maybe that's the problem?

    I tried many times without the VLAN. I tried different cables, with or without an additional DSL filter, and all different possible configurations I could think of. It always says "Event DOWN".

    Regarding the modem, it's a real modem: no router, not web interface, nothing. It's this modem:

    It's my own, not provided by the ISP. So I'm not sure what you mean by saying that the modem will take care of the VLAN itself?


  • Banned

    The openreach modems do vlan tagging to 101 as they are meant for specific providers.

    Some do have a web interface that can be unlocked, so there is a chance to change the tagging: http://www.kitz.co.uk/routers/hg612hacking.htm

    If that doesn't work you can research if the FritzBox can be set into bridge mode, or get a xDSL modem like the Draytek Vigor130 where you can configure everything yourself.



  • if that is an ECI make then you will struggle. If it's the Huawie HG612 then it's possible to change the VLAN setting, however resetting the modem will return it to the default VLAN 101 that BTOR use. I would suggest you buy the Vigor 130 as suggested as I've sampled the Fritzbox and was not overly impressed. Another really good unit is the Billion 8800NL, the Mk1 version not the Mk 2. It's dead easy to put into bridge mode and has the highest sync of any modem I've used.

    Here's the setting for wan vlan in the billion.




  • Thanks to both of you!

    I indeed decided to give up on the OpenReach and move to a better modem. I'll try the Vigor 130 as suggested, hopefully it will work fine in Ireland.



  • Tell you what, you'd be better off going for this https://www.amazon.co.uk/Billion-8800NL-Gigabit-Wireless-Router/dp/B00K6D2ESM. Superb modem, and on mine I've set it up in bridge mode, I can then also loop back in to the lan from pfSense and use the wifi, only 2.4G but I only use it for the doorbell.  ;)

    It's also a damn sight cheaper, I got mine from them.

    Only that model mind you, the Mk2 modem is not as good.



  • marjohn56, I whish I read your message before buying a Vigor 130… Apparently my problems are not over:

    https://forum.pfsense.org/index.php?topic=139000.0  :'(


Log in to reply