PfSense box not reachable after update. Lots of php warnings…



  • I have a pretty clean pfSense box that I installed and set up a year or so ago. Until today it was running 2.3.3. So I tried to update (apparently to 2.4.0) and nothing works anymore. I didn't do anything special with the machine like installing packages or other advanced things.

    The web gui keeps repeating

    Not yet ready
    Retrying in another 20 seconds

    for hours.

    I also can't ssh into the box. I can't even ping it.

    So I hooked up a monitor and saw a lot of warnings (see first attachment). 
    I did a reboot. But the same errors are popping up. 
    I tried option 13 (Update from console).  But nothing seems to happen. I see the same warnings on the screen.
    I also tried option 16 (Restart PHP-FPM). But again nothing seems to happen.
    It also seems like because of the warning messages, I can't see all options available. (E.g. it starts with option 4)
    From the shell (option 8) I tried to run pkg update -f and pkg-static update -f. But both commands just complained about a missing repo meta file and failed (see second attachment).

    How can I fix this? I don't have a backup for the configuration. And because the web gui doesn't work, I don't know how I would get one.
    But even then, I really don't want to install the machine again because that would mean downloading the image over my mobile connection which is way too expensive.

    I really hope you can help me out.





  • Does your FW have contact with the rest of the world? Can you ping google.com for example? I think the "no address record" means you have no DNS. Check your /var/etc/resolv.conf
    If it is empty you can put google-dns into it with:

    echo 'nameserver 8.8.8.8' >> /var/etc/resolv.conf
    


  • I checked and the file does not exit. I also can't ping anything from the pfSense machine. "Not route to host"

    I just ran the echo command to see if it helps, but it didn't. Then I rebooted and it still didn't work plus the file is suddenly gone again.



  • No one?



  • I had a little problem almost the same. I tried to install the latest version from the option in pfSense, but that failed, then I didn't have any contact to the "world".

    Do you have access to the webinterface? Then you could take a backup of pfSense. Install the latest version of pfSense and restore the XML file you got from the backup.

    That solve my problem.



  • try bouncing the LAN interface from the console (ifconfig if down; ifconfig if up) and then restarting php-fpm if you get a 502 error


Log in to reply