• Hi.

    I tried to update pfSense to version 2.4.0, but it failed.
    I used the builtin option in pfSense.

    Now I don't have any option to download it from pfSense. It just says "Unable to check for updates"

    And I'm not sure what to look for in the System Logs.

    Can anyone help me with this?

  • We don't have a lot to go on.  From my personal experience, anytime I've gotten the unable to check for updates message it's been a DNS issue.  Make sure your DNS is resolving correctly.

    Then, how do you know it failed?  Did you see a "System Update failed!" message and hit the power button?  If so, it didn't actually fail, PFsense just briefly lost connection with the server and then resumed its download and would have finished the upgrade in a few min.

    Personally, I would just backup your config, re-install fresh and then restore your config.  By re-installing fresh you can be back up and running in 10 min., which will save time exponentially in the end.

  • Thank you for you answer.

    I can see it didn't update because it still has the old version 2.3.4.

    In the progress of updating pfSense says you should not refresh or leave the webpage, but my computer went into hibination and then the update stopped. I tried again, but it didn't help.

  • Can you try out to download it from pfSense server direct and install it over an USB pen drive?
    Is this real 64 Bit hardware? Since pfSense 2.4.0 only 64Bit hardware is supported and not
    32Bit image will be there anytime now.

  • It was a 64bit before and after I downloaded and installed it on a USB pen drive for installing again it is working now.

    Thank you.