NAT Port Forwarding Problems



  • I have been having issues trying to port forward certain ports. It started out just to get a open NAT on Xbox but its gotten to the point that I don't think pfSense is doing anything. Whats happening is I have opened some ports for my Xbox and I have made sure that it is going to the correct IP, with the interface as WAS and the destination address as WAN also. Both source address and source ports are set to any, and the the destination ports and NAT ports are the same. The protocol is what it is supposed to be. After not seeing any results with the NAT staying the same I went back into the rules and adjusted the IP to my desktop and went to canyouseeme.org. None of the ports where open, even 80 (which didn't make any sense to me). After trying all of the ports with it adjusted to my PC, and not getting anywhere I upgraded from 2.4.0 to 2.4.1, thinking that with a new update that might fix it. I will say that it did say that both 80 and 443 where open now but if I make a rule with any other ports, I still get the same results. Is this a bug in pfSense or am I doing something wrong?


  • Rebel Alliance



  • I tried everything on the list. Nothing seems to work, and I cant think of anything else. I looked at tutorials on YouTube just to see if there was something I was missing and they are doing it the same exact way I am and it shows that its open for them.


  • LAYER 8 Netgate

    Port forwarding works fine and has for years and years and years. It's you. It is not a bug.

    Really (really) check everything on the list here. Don't just look at it and say to yourself, "that does not apply."

    https://doc.pfsense.org/index.php/Port_Forward_Troubleshooting

    Really check everything.

    Really.

    Really.


Log in to reply