Installation on a Watchguard x1250e failed. Help/hints appreciated



  • Acquired a WatchGuard X-Core x1250e box recently and trying to load pfSense on it following the guides on the internet. BIOS flashed to 8.1 and serial console worked fine. Used a SanDisk Ultra 8GB CF card on Windows using WinDiskImager with image "pfSense-CE-2.3.4-RELEASE-4g-i386-nanobsd-upgrade.img" and booted it but with the following errors:

    Trying to mount root from ufs:/dev/ufs/pfsense0 [ro,sync,noatime]…
    Configuring crash dumps...
    /dev/ufs/pfsense0: FILE SYSTEM CLEAN; SKIPPING CHECKS
    /dev/ufs/pfsense0: clean, 2873225 free (2345 frags, 358860 blocks, 0.1% fragmentation)
    Can't stat /dev/ufs/cf: No such file or directory
    Stopping boot is recommended because filesystem manual action is needed, nevertheless automated repair of the filesystem will be attempted.
    WARNING: Trying to recover filesystem from inconsistency...
    ** /dev/ufs/pfsense0
    ** Last Mounted on /builder/pfsense-234/tmp/pfSense/_.mnt
    ** Root file system
    ** Phase 1 - Check Blocks and Sizes
    ** Phase 2 - Check Pathnames
    ** Phase 3 - Check Connectivity
    ** Phase 4 - Check Reference Counts
    ** Phase 5 - Check Cyl groups
    16071 files, 906803 used, 2873225 free (2345 frags, 358860 blocks, 0.1% fragmentation)

    ***** FILE SYSTEM IS CLEAN *****
    Can't stat /dev/ufs/cf: No such file or directory
    Can't stat /dev/ufs/cf: No such file or directory
    ** /dev/ufs/pfsense0
    ** Last Mounted on /builder/pfsense-234/tmp/pfSense/_.mnt
    ** Root file system
    ** Phase 1 - Check Blocks and Sizes
    ** Phase 2 - Check Pathnames
    ** Phase 3 - Check Connectivity
    ** Phase 4 - Check Reference Counts
    ** Phase 5 - Check Cyl groups
    16071 files, 906803 used, 2873225 free (2345 frags, 358860 blocks, 0.1% fragmentation)

    The above "FILE SYSTEM IS CLEAN" repeated 10 times then the following error message:

    ***** FILE SYSTEM IS CLEAN *****
    Can't stat /dev/ufs/cf: No such file or directory
    Can't stat /dev/ufs/cf: No such file or directory
    ERROR: Impossible to mount filesystem, use interactive shell to attempt to recover it

    Then it dropped into a shell with a # which I can type command in.

    I have set the BIOS to CHS mode with heads=2. And tried Auto but the same error. Also tried 2.2 and 2.3.3 images but the same.

    So some questions:

    1. Am I using the correct image file to install? (I found it's name contains Upgrade so thought is there an Install image?)
    2. Anything I missed/did wrongly caused this error?
    3. Any one had/heard the same issue?

    Thanks for any hints.


Log in to reply