SG-4860 ugprade to 2.4.0 failure - need a little help



  • With the release of 2.4.1 I decided to upgrade my sg-4860 to the latest pfsense release. turns out this was a bad idea.

    first attempt failed. rebooted and tried again. apparent success except the device never came back on the wire.

    went and connected usb cable and consoled in. the box is booted and sitting at the logon prompt. no network access to it at all however.

    i log in using the credentials i setup and get the 16 item menu 1. 2. etc… but none of the operations work. i can't assign interfaces or set ip addresses. i can't reboot or reset factory defaults or ... every menu item selected just reset the console back to the original 16 item menu. i'm stuck in an infinite loop.

    I can access the shell, #8 and I can start pftop, #9 but that's it.

    I'm very new to pfsense and the netgate device so I'm at a bit of a loss as to where to start. Any help or advice would be greatly appreciated.



  • I hope you did a backup prior to upgrading right?

    If so reinstall clean, and then restore the backup.



  • Yep. I did a backup first.

    Just needed a pointer in the right direction which I got on fb from a kind soul.

    All recovered now, thanks.



  • Yep. I did a backup first.

    If you have done this right, and you are upgrading to the version 2.4.1 and gets out problems and issues too,
    I would suggest to do a fresh and full install once more again and also play back the backup file once more again!

    Just needed a pointer in the right direction which I got on fb from a kind soul.

    Please ensure that you are using the ADI-AMD-64Bit-Serial version of pfSense!

    All recovered now, thanks.

    Keep thre eMMC storage up to date and install a small mSATA that fits your needs and you get a fast backup system!
    Sometimes time will be not even there, and so you might be able to get a working platform fast back.


Log in to reply