Upgrade to 2.4.x

  • Since I upgraded to 2.4.0 (and later 2.4.1) i got this alert, like I still have sarg package installed, but I don't actually.
    Do i have to remove some scheduled task?

    PHP ERROR: Type: 64, File: /usr/local/pkg/sarg.inc, Line: 36, Message: require_once(): Failed opening required 'xmlrpc.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear') @ 2017-10-25 23:00:00

  • Rebel Alliance Developer Netgate

    Look in /usr/local/pkg/ and see what files from sarg are still there. At least /usr/local/pkg/sarg.inc is there causing trouble. Since you don't have the package anymore, it's safe to remove that. That should be enough to stop that particular error.

  • Did that, and also followed the suggestion on https://forum.pfsense.org/index.php?topic=47765.msg638542#msg638542

    Removed also the config.xml entries that was still here.

    Will see if the problem still occur at 11PM.

    Thanks for that  ;D

Log in to reply