Wifi sulla LAN



  • Ciao a tutti , riepilogo la mia configurazione :

    server pfsense 2.3.4 p1 con WAN e LAN

    la WAN va su router -> e poi internet
    la LAN e' la rete interna con classse 192.168.1.x

    fa lui da DHCP

    il server e' sulla stessa rete

    ho collegato un ap wifi, tolto il dhcp e messo ip statico 192.168.1.253 , messo pss sul wifi

    a sto punto collego un apparato in wifi, il dhcp di pfsense da l'ip al apparato e funziona ma praticametne ogni minuto non naviga, poi riprende, poi non naviga, poi naviga ecc ecc, e' come se tramite wifi la connessione WAN non va sempre, la rete invece funziona perfettamente

    avete idee? forse non e' la configurazione ideale? consigli?
    ma sopratutto come posso vedere, in qualche log, cosa succede quando non naviga? almeno per capire ed intervenire

    ps. fino a qualche tempo fa funzionava, poi dopo qualche aggiornametno e' successo cio'.



  • nessuno sa darmi una mano?



  • Ciao,
    mi sembra più un problema dell'AP.
    Prova a tenere un pc connesso in wifi e fai un ping costante al pfsense e vedi se cade
    Ciao



  • Ciao Fabio no dal wifi al pfsense non cade , cade solo la parte internet ha delle pause sulla parte internet, cmq provo a farlo e vedo , ma se cosi' fosse dici che e' proprio un problema tecnico ? ma me lo fa anche con un vecchio wifi, e' come se non lo accetta sulla rete al 100%



  • Ciao Fabio, avevi ragione se mi collego con un pc in wifi e pingo pfsense ogni 2/3 risposte mi da non raggiungibile e continua cosi'

    secondo te cosa puo' essere? devo aprire qualche regola su pfsense?



  • L'AP è connesso ad una porta di pfSense o allo switch?
    Secondo me potresti avere un problema sul tratto AP <-> firewall il che include la possibilità di problemi ad un cavo, all'ap o allo switch

    Fai altre prove tipo da un pc in wifi pinga un pc connesso via cavo allo switch

    Ciao Fabio



  • ciao Fabio, allora l'AP e' collegato da una lan sua allo switch della rete, ha il suo DHCP disattivato ovviamente, e ha un ip fisso della stessa rete, in modo che posso collegarmi per gestirlo

    se collego un pc via lan funziona benissimo, via wifi da quel problema



  • Ciao,
    hai fatto la prova che ti avevo chiesto?
    E'fondamentale andare per gradi e capire dove si interrompe la connessione. Se già il ping da un dispositivo wifi verso un dispositivo della lan perde pacchetti, allora il problema non è sicuramente pfsense ma potrebbe essere l'AP o il cavo tra AP e Switch

    Ciao Fabio



  • ciao domani mattina sono in sede e lo faccio  , ti faccio sapere

    quindi da wifi verso pfsense perde
    provo come dici e vediamo e ti dico subito domani mattina



  • Ciao Fabio, fatto le prove allora :

    se mi collego sullo switch pingo l'AP tutto ok,
    se mi collego sulal porta switch del AP e pingo il pfsense tutto ok se pingo altri pc della rete tutto ok
    se mi collego tramite wifi e pingo l'AP tutto ok se pingo pfsense tutto ok se pingo pc della rete perde molti pacchetti

    come mai secondo te? anche io ho pensato ad un difetto del AP ma la cosa strana e' che se pingo pfsense fa tutto bene

    l'AP e' collegato tramite switch sulla rete, configurato senza DHCP attivo e come AP nulla di particolare, acquisisce tranquillamente gli ip dal dhcp di pfsense



  • nessuna idea?



  • Ciao credo che il mio problema sia il pfsense, spiego perche', dopo aver fatto mille prove , il problema di connessione lo ho solo se mi collego via wifi, va a tratti , come giustamente diceva Fabio, poteva essere a sto punto un AP difettoso, ho provato a cambiarlo con un altro, e il problema rimane, questo altro AP e' il mio di casa , e a casa funziona benissimo, stessa cosa il principale girato a casa mia funziona benissimo

    come posso capire sta cosa? su pfsense come individuo questo problema decisamente strano?



  • Ciao!!!

    Potresti essere più specifico nel descrivere il tuo hardware nel senso PFS su cosa gira?
    Di quante interfacce dispone solo 2 è possibile un upgrade hardware?
    Riguardo al tuo AP ti da la possibilità di gestire il client  che si connettono con un DHCP suo invece che appoggiarti a quello di PFS?

    Poi ho dei dubbi nel interporre uno switch tra il firewall e l'AP se ne hai la possibilità prova a collegarlo direttamente a PFS con una /30 tra PFS e l' AP e dal li lasci che sia lui a gestire il DHCP per il client Wireless.
    Inoltre è da considerare il contesto in cui ti trovi ad operare enterprise, soho, home, ecc.
    Personalmente se possibile cerco di isolare gli accessi WLAN da quelli LAN.



  • ciao robby grazie della risposta

    allora prima che ti descrivo la cosa e' giusto che ti dica che fino a quando si bruciava un vecchio tplink andava tutto, poi si e' rotto e l'ho sostituito e da li e' iniziato tutto

    per usarlo con una /30 posso pure farlo e abilitare il dhcp , ma poi come uso la stessa rete? ho un dominio e i pc fanno il logon se si dovessero connettere sul AP cambia ip e non vedrebbero piu' la rete ma solo la navigazione, o posso anche fare in modo che la vedo?



  • ok! per tua necessità le reti devono essere sulla stessa subnet.
    praticamente tu hai pfs>switch>ap>WLAN.
    Pfs ti fa da server DHCP?
    Anche per AP che ha un IP fisso? Hai controllato che lo faccia(cioè IP assegnati ad ap sempre lo stesso e hai client nel range-DHCP scelto)?

    Se non lo hai già fatto io proverei una reservation sul server DHCP di pfs cioè a riservare l'uso di un IP solo per ap.
    dalla scheda Services>DHCPServer>DHCP Static Mappings for this Interface>add bastano MACAddress IPRiservato e Hostname.



  • si l'ap ha un ip fisso, il dhcp lo fa il pfsense e ha un range al di fuori degli ip fissi che uso sulla lan

    esempio il dhcp parte da 1 e arriva  a 150 , tutti gli ip fissi che uso sono dal 151 in poi

    chi si collega tramite AP ha un ip corretto ma come ho detto dall'inizio ha una discontinuita' di navigazione e rete e' come se ogni 10/15 secondo facesse una pausa e poi riprende sempre cosi', sto diventando matto



  • ok! capito che hai problemi! ;)

    Fammi solo capire,
    es.: /24 Ip da 2 a 150 per il DHCP dei client.

    si l'ap ha un ip fisso, il dhcp lo fa il pfsense e ha un range al di fuori degli ip fissi che uso sulla lan

    Ok sul AP hai un IP fisso.
    Ma su PFS nel server DHCP hai fatto la reservation (vedi post precedente) per l' IP che hai assegnato all'AP ?
    Hai un pool dhcp aggiuntivo-i?( di cui uno per l'AP)

    Se non hai bisogno di pool dhcp aggiuntivi ma devi usare altri IP, cercherei di riservare gli ultimi, es. 254 per l' AP, 253 per il NAS, ecc.
    Quindi se non lo hai fatto prova ha riservare con il ServerDHCP di PFS l'IP che hai assegnato all'AP.

    Una traccia su come fare l'ho lasciata nel post precedente ma se dovessi aver dubbi mi trovi quì ! :)



  • ciao nulla da fare ho riservato l'ip ma funziona sempre nello stesso modo