Cache navegadores



  • Prezados, boa noite!

    Meu PFsense está configurado em proxy Transparente e utilizo o squidguard para bloquear páginas. Utilizo certificados nos clientes. Acontece que, toda vez que modifico algo no SquidGuard tenho que limpar o Cache dos navegadores para que as alterações sejam aplicadas.

    Cache do squid:
    heap LFUDA
    Memory Replacement Policy
    heap LFUDA
    Select to enable caching of dynamic content (marcado e desmarcado não funfou)

    Alguém pode me ajudar?

    Grato!



  • Reinaldo, comigo tem funcionado, mas eu uso o "Heap GDSF" em "Memory Replacement Policy". Também não ativo o "Select to enable caching of dynamic content" (já tive problema com essa opção ativada antes então deixo desativado). 
    Mas sempre que eu faço uma mudança significativa nas regras do squidguard eu limpo o cache do squid mesmo. Mas o seu problema eu nunca tive.



  • Gustavo, primeiramente, obrigado por responder. Pois é, rapaz! Já tentei configurar de todas as formas e não obtive êxito. Se eu removo um determinado site de uma lista de bloqueios do Squidguard ou se tento acessar o site bloqueado em outra rede em um computador que estava com o as regras do Squidguard, somente depois de limpar o Cache do navegador é que ele acessa.

    Tá osso!



  • @Reinaldo.Pereira:

    Gustavo, primeiramente, obrigado por responder. Pois é, rapaz! Já tentei configurar de todas as formas e não obtive êxito. Se eu removo um determinado site de uma lista de bloqueios do Squidguard ou se tento acessar o site bloqueado em outra rede em um computador que estava com o as regras do Squidguard, somente depois de limpar o Cache do navegador é que ele acessa.

    Tá osso!

    Lá na tela do proxy filter (squidguard) que opção colocaste no "redirect mode"??
    eu uso o padrão "int error page" e não dá problema, mas já tive problemas semelhantes usando outras opções! Se vc estiver usando a "ext url error page" tenta alterar para a "ext url error found" (e vice-versa) que talvez resolva seu problema também!



  • Reinaldo, tudo bem?

    Lá na tela do proxy filter (squidguard) que opção colocaste no "redirect mode"??

    O UnDrEaD lembrou bem dessa opção. O que você colocou? Eu uso a opção "int error page".



  • Prezados, mais um vez, agradeço por responderem. Utilizo o padrão: "Int error page". Tentei outras opções e nada. Toda vez que tiro um site da blacklist tenho que limpar o cache dos navegadores para que ele possa acessar.



  • @Reinaldo.Pereira:

    Prezados, mais um vez, agradeço por responderem. Utilizo o padrão: "Int error page". Tentei outras opções e nada. Toda vez que tiro um site da blacklist tenho que limpar o cache dos navegadores para que ele possa acessar.

    Amigo, não sei se é seu caso, mas tente isto caso os SO das maquinas sejam o Windows.
    (Do pfsense entendo quase nada, mas o Windows eu conheço um pouco rss)
    Painel de controle, Opções da Internet, aba Geral, "Histórico de navegação" Botão configurações.
    Aí só selecionar " Sempre que eu visitar a Página da Web" aplicar para salvar.
    Dependendo do caso tem que configurar na GPO, abraços. (Vai que da certo rss)



  • Andinho, nada feito! Não funfou. Mas obrigado pela dica!

    Quem puder ajudar…...



  • Reinaldo, qual é a versão do seu pfsense e do squid?



  • Gustavo, boa tarde! Pfsense 2.3.4, Squid: 0.4.40, Squidguard: 1.16.3



  • Alguem teve sucesso? estou com o mesmo problema


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy