Upgrade from 2.3.4 to 2.4.1 worked like a charm!!!



  • Just a positive note: just upgraded my SG-4860 from 2.3.4 to 2.4.1. Did a fresh install and used the "recover from previous configuration" feature. Changed to ZFS. System did it's thing, came back up again, config was all in place, HD is on ZFS now and everything works perfectly! It just works! Well done guys! Great job!  ;D



  • To do a fresh install and the "recover from previous configuration", should the configuration file be on the installation USB flash drive as the install?



  • I'm not a Dev, but from what it looked like to me, the config is copied to a /tmp directory which is not deleted during the installation. After successful installation it takes that copy of the config and imports it and reboots into the correct config. Was a very smooth upgrade for me!



  • Thanks.  I wasn't sure if I needed to ensure that a copy of the config file is available during a fresh install to use the "recover from a previous configuration" option.  I assumed a fresh install would wipe out the local drive prior to the installation, especially if I switch to ZFS from my current file system.



  • It worked perfectly for me. But having a backup of your config somewhere can never be a bad idea…..!


Log in to reply