Install on Intel NUC 6CAYH - Freeze on 'Timecounter "HPET" frequency 19200000 Hz



  • I'm trying to install the latest version of pfSense on the Subject line Intel NUC. It's a brand new machine, never been used. I have 6 gb of ram in it and a 500gb HDD. I've tried adjusting the settings in the bios, but no avail. I have installed the latest version of the bios (0041), so I don't think that's the problem. Anyone experienced this? Any ideas?
    Thanks,
    Randy
    ![Picture 1.jpg_thumb](/public/imported_attachments/1/Picture 1.jpg_thumb)
    ![Picture 1.jpg](/public/imported_attachments/1/Picture 1.jpg)



  • Try to add the following line in /boot/loader.conf.local as well as /boot/device.hints
    hint.hpet.0.clock=0

    (Having it in one of the files should suffice but I can't remember which, as I did this once some time ago.
    In any event it won't harm your system if you have it in both places)

    Alternatively you might want to go into your NUC's BIOS and check the ACPI section.
    If there is something called CSM or Compatibility Support Mode or Legacy Compatibility mode which is ON try to turn it off and reboot.



  • @haleakalas - Forgive my ignorance, how would I edit those files? I when I put that USB disk in my windows box it doesn't show the directory structure.

    Tried disablign HPET in the bios, no luck. Cand find CMS



  • @rdjack:

    @haleakalas - Forgive my ignorance, how would I edit those files? I when I put that USB disk in my windows box it doesn't show the directory structure.

    Tried disablign HPET in the bios, no luck. Cand find CMS

    I just realized that when I faced a similar HPET message my system was already installed and the message was popping up from time to time and freezing the router, but when it was running fine I could access it via SSH and once I had shell access in root mode I could use any file editor (like nano on my linux machine) to edit those files.
    But as your system is not installed yet, those files are not on the hard drive's /boot, so my suggestion might not work at all.

    Sorry for the confusion I might have caused. I'll look into my maintenance notebooks and see what I can find. We do maintain about 65 pfsense SOHO routers and they are all one of a kind hardware.



  • Ok, here comes some more info from our engineering notebooks:

    At boot:
    In the pfSense boot menu, select option 3 to open the console, then issue the command:
    set hint.hpet.0.clock=0
    hit enter,
    next issue the command:
    boot
    hit enter again and the router should boot normally.

    To make this persistent the following needs to be done once the machine is installed and up and running:

    Edit /boot/loader.conf.local
    and insert the following line at the end of the file:
    hint.hpet.0.clock=0

    Save the file and reboot to confirm that everything works again.



  • You could also press 6 in Boot menu and then enable the "Safe Mode" for installing.
    That way you dont have to press too many buttons :)



  • @haleakalas:

    Try to add the following line in /boot/loader.conf.local as well as /boot/device.hints
    hint.hpet.0.clock=0

    (Having it in one of the files should suffice but I can't remember which, as I did this once some time ago.
    In any event it won't harm your system if you have it in both places)

    Alternatively you might want to go into your NUC's BIOS and check the ACPI section.
    If there is something called CSM or Compatibility Support Mode or Legacy Compatibility mode which is ON try to turn it off and reboot.

    Sorry to bring up a relatively old post but I just wanted to thank you for this.  I've never had this issue until I tried to upgrade to 2.4 this morning.  Adding this line to /boot/loader.conf.local got me back up and running.  Thanks again!


Log in to reply