Pfsense 2.4.x on Asrock Q1900M



  • Anyone get pfSense 2.4.x running on an Asrock Q1900M yet?  Mine reboots in the middle of initializing the various USB controllers the motherboard exposes (inits the first, reboots on the second).



  • The ASROCK Q1900M is using the Intel J1900 and due to the lag of the AES-NI function or CPU register
    it might be only running well until the version 2.5 will be out there and we are now on the version 2.4.1 only
    as a side note on this!

    You can try out to go into the BIOS and then disabling the USB ports complete or you set them to work in
    the so called "usb legacy mode" that might be a better chance to get it installed right on that board.

    To be sure there is nothing known and fixed all right now, is there the latest BIOS is on that board?
    If not install it please.

    Do you installing over an USB CD/DVD-ROM drive? This could also causing that problem.



  • Yeah, I'm aware of the 2.5/AES-NI issue with my board, but if I can make it until then, available hardware should be year newer in design.

    I have considered disabling the USB ports, but I've been trying to avoid digging out a SATA dvd drive to install from.  I've been installing off a USB memstick, though it still has the problem if you just run the upgrade from the web-gui.



  • Can you install/boot pfSense with "Safe Mode" enabled in boot menu?



  • Try disabling unused devices like onboard audio card etc….
    I use the Asrock D1800M , the previous model with also no AES-NI cpu, and this works fine with 2.4.1 ,
    so it's not an AES-NI issue.
    Where do you want to install pfSense ? HDD, SSD, USB-drive ?

    Grtz
    DeLorean



  • Update for anyone with similar problems

    So, things I've tried so far.  Updated BIOS.  No Dice.  Disabled USB.  Same problem, just crashes a little further on in the boot cycle.  At this point in time, I've spent more time than the hardware is worth, and I'm still going to have the AES-NI issue when 2.5 comes out, so time to just bite the bullet and replace the mobo/cpu.



  • DeLorean, I've seen you mention that you've used the QC5000M in other threads.  Have you upgraded one to 2.4 yet?  It seems that would be a pretty simple and cheap way to solve the AES-NI problem with 2.5 when it comes out.



  • @wzochert:

    DeLorean, I've seen you mention that you've used the QC5000M in other threads.  Have you upgraded one to 2.4 yet?  It seems that would be a pretty simple and cheap way to solve the AES-NI problem with 2.5 when it comes out.

    I have build several firewalls with the Asrock QC5000M in a Supermicro 1U chassis, and these work also pretty fine without any problems,
    very silent, low power draw (arround 17Watt idle @ 220V) and…......AES support :-)

    Grtz
    DeLorean


Log in to reply