NTOP Issues



  • Howdy, running 1.2.1RC2 Build Tue Dec 2 13:22:33 EST 2008. Tried out the new NTOP package and it refused to load. I opened a connection in firewall rules to port 3000, set the gui password, indicated LAN for the interface, and even rebooted. No luck. Let me know if I can provide further info to help this along or if I have overlooked something. NTOP fulfills my need for pretty graphs:)



  • I noticed this too, it seems rrdtool wasnt being installed which is required for ntop to run, I managed to install this manually and ntop now works fine.

    regards



  • How very silly. I will give that a crack and see how it works. Thank you.


  • LAYER 8 Global Moderator

    Yeah install rrdtools worked

    pkg_add -r rrdtools



  • Still having issues. I installed rrdtools via "pkg_add -r rrdtool", installed ntop from the gui, and still no access what so ever.

    I have made sure that the firewall rules allow access to port 3000 on the LAN, have set ntop settings appropriately (LAN, password entered), and have rebooted following installation. Netcating the port shows that the connection to 3000 is timing out instead of showing open, even on a firewall with all rules set to open access. Logs show nothing related to netcat apart from installation and I have reinstalled both the package and the gui from pfsense's gui.

    To johnpoz, did you install rrdtool before installing ntop or after?





  • Most excellent, freeradius trick was the fix. Thank you.


  • LAYER 8 Global Moderator

    Yeah I had freeradius already installed, so the rrdtools fixed it for me.



  • I was having issues myself after installing NTOP and no NTOP site - what I had to do was reset my NTOP password to "normal" characters - uppercase, lowercase, numbers combo and NOT the weird characters I was intially using.



  • @ryates:

    see http://forum.pfsense.org/index.php/topic,12976.0.html for a work-around.

    ryts

    What was the working around? that thread I believe was deleted



  • Hi All,

    For some reasons for me the ntop 3.3.8 doesn't work after upgrading from 1.2.1-RC4 to the 1.2.1 release (upgrade with full .gz). It refuse to start. After troubleshoot for a while and no luck i decided to install with fresh cop of pfsense. Backup the config file and reinstall, everything works like charm!

    Thanks,

    CQ



  • For me, installing the Freeradius package fulfilled whatever dependencies were missing. That being said, I ceased using NTOP while still in 1.2.1. No idea if the problem was fixed by the time 1.2.2 was released. We're moving to a centralized network monitor anyway and will probably rely on SNMP traps for making pretty charts from now on.


Log in to reply