There were error(s) loading the rules



  • Hi Guys,

    I started having some connectivity issues late last week. The WAN connection was dropping out intermittently

    I left it over the weekend as I assumed it was an IP provider issue as the PF Sense box has been running without an issue for months!

    When I log into PFSesne this morning I see multiple messages:

    There were error(s) loading the rules: /tmp/rules.debug:18: cannot define table bogonsv6: Cannot allocate memory - The line in question reads [18]: table <bogonsv6> persist file "/etc/bogonsv6"
    

    I also upgraded to the latest version 2.4.1 to see if that helped clear the errors but they are still there and the Wan connection keeps dropping.

    I have a computer plugged into the IP modem and it has connection without any issues.

    Is this likely that these issues are connected? Any idea how I can fix them?

    Edit

    I am also seeing:

    pf_busy

    PF was wedged/busy and has been reset. @ 2017-10-31 11:16:48
    Filter Reload

    There were error(s) loading the rules: pfctl: DIOCXCOMMIT: Device busy - The line in question reads [0]: @ 2017-10-31 11:16:49



  • Same here:

    There were error(s) loading the rules: /tmp/rules.debug:26: cannot define table bogonsv6: Cannot allocate memory - The line in question reads [26]: table <bogonsv6>persist file "/etc/bogonsv6"

    Sometimes also:

    There were error(s) loading the rules: /tmp/rules.debug:34: cannot define table XXX_Netze: Cannot allocate memory - The line in question reads [34]: table <xxx_netze>{  94.XX/20  92.XXX/21  2a00:XXX::/29 }</xxx_netze></bogonsv6>



  • Hi,

    the Problem is coming over many times a day.
    Does nobody else has had this problem?

    Thanks



  • This is the key word :

    Cannot allocate memory
    

    Also check drive space and disk allocations.

    If needed, stop en remove the "memory eaters" (packages - and I'm not talking about the cron - or note package here  ;))



  • @Gertjan:

    This is the key word :

    Cannot allocate memory
    

    Also check drive space and disk allocations.

    If needed, stop en remove the "memory eaters" (packages - and I'm not talking about the cron - or note package here  ;))

    Hi Gertjan,

    that's not a Problem of mine. The Server has a CPU Load from 3-4 Percent and a low Mem usage.
    I found out that the Message and the Problem happen, if a Gateway has Packetloss and it's marked as down. Than the Error is generated. Also if the GW is coming up again. I think this is a bug that has been checked.
    As workaround i disabled the gateway-check. Than nothing error happen.