[RESOLVIDO] pfSense 2.4.1 + winbind NTLM + Squid (Iniciante)



  • Estou tendo dificuldade para fazer a integração do SQUID com o AD via winbind NTLM.
    Executo o Script do Luiz Gustavo (fetch -q -o - https://pkg.mundounix.com.br/pfsense/2.4.1/samba/pf2ad.sh | sh) via Shell, mas creio que nem todos os pacotes são instalados.  Após a instalação, tento integrar o pfSense ao AD, mas ele não integra.

    Informações adicionais:

    Ao executar o comando #ps ax |grep smb
    Resultado: [2.4.1-RELEASE][root@pfSense.CEOSGA.COM]/root: ps ax | grep smb
    17161  0  R+    0:00.00 grep smb

    Ao executar o comando #net ads info
    LDAP server: 10.82.0.21
    LDAP server name: SRVCEOSGA.CEOSGA.COM
    Realm: CEOSGA.COM
    Bind Path: dc=CEOSGA,dc=COM
    LDAP port: 389
    Server time: Tue, 31 Oct 2017 23:01:01 -03
    KDC server: 10.82.0.21
    Server time offset: -3591
    Last machine account password change: Tue, 31 Oct 2017 23:00:23 -03

    Verifiquei também se a senha do administrador do AD estava incorreta e a mesma não estava.

    Conto com vocês ;D

    O problema estava no virtualbox, onde eu estava emulando o pfsense. Após a reinstalação do aplicativo, tudo voltou ao normal.



  • Tento subir o serviço do samba manualmente? Alguma coisa nos logs?



  • veja se o serviço esta iniciado, execute os comandos abaixo veja o resultado:

    wbinfo -u -p

    net ads info

    tente contato com o desenvolvedor ele responde: "Luiz Gustavo dos S. Costa" luizgustavo@mundounix.com.br



  • @empbilly:

    Tento subir o serviço do samba manualmente? Alguma coisa nos logs?

    Não encontrei tutorial sobre como instalar o samba manualmente.

    obrigado



  • @dreivi:

    veja se o serviço esta iniciado, execute os comandos abaixo veja o resultado:

    wbinfo -u -p

    net ads info

    tente contato com o desenvolvedor ele responde: "Luiz Gustavo dos S. Costa" luizgustavo@mundounix.com.br

    Após executar os comandos wbinfo -u -p:
    could not obtain winbind interface details: WBC_ERR_WINBIND_NOT_AVAILABLE
    could not obtain winbind domain name!
    Error looking up domain users

    Após executar os comandos wbinfo -u -p:

    LDAP server: 10.82.0.21
    LDAP server name: SRVCEOSGA.CEOSGA.COM
    Realm: CEOREGIONAL.COM
    Bind Path: dc=CEOSGA,dc=COM
    LDAP port: 389
    Server time: Thu, 02 Nov 2017 23:01:17 -03
    KDC server: 10.82.0.21
    Server time offset: -3592
    Last machine account password change: Wed, 31 Dec 1969 21:00:00 -03

    Vou tentar Falar com oLuiz gustavo
    Obrigado



  • miqueiaosusa011, como conseguiu resolver esse problema?

    Estou com a mesma mensagem de erro ao executar o comando wbinfo -u:

    could not obtain winbind interface details: WBC_ERR_WINBIND_NOT_AVAILABLE
    could not obtain winbind domain name!
    Error looking up domain users



  • Funcionou. Foi só reiniciar o servidor. Valeeu



  • Alguém resolveu o problema? Já reiniciei e nada…

    wbinfo -u -p
    could not obtain winbind interface details: WBC_ERR_WINBIND_NOT_AVAILABLE
    could not obtain winbind domain name!
    Error looking up domain users

    net ads info
    ads_connect: No logon servers
    ads_connect: No logon servers
    Didn't find the ldap server!