Wireless Clients Unable to Get DHCP after upgrading to 2.4.1



  • Hi Everyone,

    I recently upgraded my pfsense to 2.4.1 (from 2.3.4).
    The PFSense is my L3 device.
    I also have a R8000 Netgear router which acts as an AP (Using tomato firmware).
    Ever since the upgrade, my wireless devices are no longer able to grab DHCP.
    I am now using the R8000 as a Router which is double NAT which I prefer not to.

    Troubleshooting steps that I did:-

    • tried to downgrade back to 2.3.4 (not able to install any packages after downgrade, therefore remained with 2.4.1)
    • tried to set static IP to confirm connectivity but I am not able to ping the gateway.
    • unplug the cable on the back of the R8000 and connect it via wired to my laptop, and I was able to get DHCP IP (which means connection to the PFSense is there)
    • I am also able to access my AP in my network, its only that my DHCP for my wireless device is not working

    When I open the system logs in PFSense, I noticed that:-

    • I got the dhcp discover packet from my wireless device
    • Pfsense sends back the dhcp offer packet
    • pfsense does not receive the request packet

    There was no changes done on my AP, just an upgrade on the PFSense cause the issue.
    Can anyone shed a light on why this has happened?
    Could it be something to do with the patch on KRACK that was done in 2.4.1?
    Thanks.



  • I have the same problem:
    my pfsense work as captive portal wired and wireless,  after the upgrade to 2.4.1 the dhcp server stop distribute ip, and when I try to see the dhcpd.leases file the system has a crash in web interface



  • Hi Paoloc,

    Thanks for the check.
    I actually downgraded back to 2.3.4 right now and still got the same issue.
    I actually did further and perform a packet capture where I found that the DHCP discover packet was recevied from the pfsense.
    The pfsense actually sents out a dhcp offer packet out back.
    However, the offer packet was not received on the R8000.
    Not too sure why at this stage.



  • Hmmm ok, found out more.
    Maybe any gurus can help me out?

    Did a packet capture of a few scenarios:

    1. When a wireless device is trying to grab DHCP
    • found out that the message was send as a broadcast from Device to PFSense - DHCPDiscover
    • found out that the DHCP Offer was send back as a Unicast message (which is a bit weird)
    1. When a wired connection is trying to grab DHCP
    • found DHCP Discover packet was send as a broadcast requesting for an IP
    • did not see the DHCP offer packet from the PFsense
    • saw a few dhcp request packet
    • PC was able to get the dhcp ip

    I thought that this could be due to the fact that the PC previously have a static entry in the DHCP Server.
    So i removed it and perform the DHCP again.

    1. When a wired connection is trying to grab a DHCP and the MAC is not statically assigned
    • same issue as scenario 1
    • PC is not able to grab dhcp

    So it seems like any wired is able to get statically assigned DHCP IP.
    If they are not static, it will not work.

    I then proceed to check on the /var/dhcpd/var/db/dhcpd.lease file where every DHCP IP should be in there, but the file size is less than 1KB at the moment.
    I have more than 40 network devices in my network, mostly wireless.
    I have at least 10 wired devices which should be in the dhcpd.lease file (correct me if I am wrong).

    I then proceed to delete the dhcpd.lease and dhpcd.lease~ file, turn off the dhcp server service and turn it back on to recreate the file.
    Still the same, no difference.

    Any kind gurus can help me out?

    Any kind gurus can advise me what could I do


Log in to reply