Help with NTP



  • I know this has been addressed over and over, and I've read all of the threads I've found, but I have made little progress, so I turn to the community for help.

    Running Community Edition, version 2.4.1 RELEASE

    In Services->NTP->Settings

    Interface: none selected (also tried with only WAN, only LAN, and both selected)
    Time Servers: 4 pools specified
    All other settings are at default

    Options on ACLs tab are default as well.

    From a shell, I can get it to update manually using ntpdate command. In the screenshot attached, you can see the first time I run the command, it says that the NTP socket is in use, so I stopped the service form the GUI. Second time, it says that there's no suitable server. After I add the -u option on the third attempt, it seems to synchronize successfully.

    In the status screenshot, it appears that I'm not connecting to any of the servers listed. I've tried adding rules to allow port 123 going any direction from any source to any destination, no change.

    Can anyone suggest something that may help me figure out why this isn't working?





  • Just a guess but I suspect ntpd is bound to that socket, and the settings you're putting into pfSense are for ntpd, not ntpdate.



  • That makes sense. I included the bit about the socket being in use mostly to illustrate it's at least trying to update, but I still don't understand why it can't connect to any of them



  • Go to Services - NTP.  Select your LAN.  Fill in your pools.  Done.



  • I intended to go back and set it that way, get screenshots, and come back here to post "I told you so, it didn't work"… but I'll be damnd if it isn't indeed working.

    Thank you very much for setting me straight.


Log in to reply