Error after update 2.4.1



  • Hello,

    After the update Pfsense 2.4.1.
    I do not have a connection anymore LAN access and more ping on the interface.

    Here are the error messages during startup VM.

    Can you help me please  :(



  • Do you remember if you currently have squid installed?
    I think it was removed in the past on your installation, but some old file(s) didnt get removed then. Remove the squid.inc file shown in the message and try another reboot.



  • Good, thank you very much  :)

    It works after the reboot.

    Here is the crash report :

    ###########
    Crash report begins.  Anonymous machine information:

    amd64
    11.1-RELEASE-p2
    FreeBSD 11.1-RELEASE-p2 #6 r313908+7eae9364d25(RELENG_2_4): Sun Oct 22 17:32:35 CDT 2017    root@buildbot2.netgate.com:/builder/ce-241/tmp/obj/builder/ce-241/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [04-Nov-2017 14:49:00 Europe/Paris] PHP Fatal error:  Call to undefined function install_package() in /etc/inc/pkg-utils.inc on line 639
    [04-Nov-2017 14:49:00 Europe/Paris] PHP Stack trace:
    [04-Nov-2017 14:49:00 Europe/Paris] PHP  1. {main}() /etc/rc.start_packages:0
    [04-Nov-2017 14:49:00 Europe/Paris] PHP  2. sync_package() /etc/rc.start_packages:58

    Filename: /var/crash/minfree
    2048
    ###########

    Thank you for your help



  • Can you re-install squid package from system/packages? Somehow its not fully correct in its current state and failing to reinstall a package it knows it wants to have..



  • Thanks a lot PiBa, fixed  ;D



  • Oké thanks for the update.
    Just fyi and anyone else running into that last error "undefined function install_package()" i have made a little fix for that: https://github.com/pfsense/pfsense/pull/3866


Log in to reply